Bug 128913 - No disk /dev/hda found, /dev/hdc instead
No disk /dev/hda found, /dev/hdc instead
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-31 07:13 EDT by Leonard Evens
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-01 13:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard Evens 2004-07-31 07:13:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I want to install FC2 on a Dell Inspiron 1100 as a dual boot with XP
machine.  I resized the XP partition using Partition Magic.  I know
about the XP bug in the FC installer and the suggested solution which
is to tell the installer the CHS geometry of the disk.  So I ran the
FC2 rescue CD and tried to find that.  I found no hda in dev, only
hdc.  fdisk -l /dev/hdc gave the expected partition information.  I
then ran the installer invoking Disk Druid to do the partitioning but
stoppes short of actually doing anything.   Again it showed me only
/dev/hdc with the expected partition.  Checking the boot and other
messages with Ctrl-Alt Fn for different n seemed to indicate that the
CD drive was /dev/hda.

It is possible that Dell reversed the hard drive and CD drive on the
IDE controller ports,  putting the disk on ID1 instead of ID0.  They
could have done this either on purpose or by accident.  But I thought
that XP had to be on /dev/hda in order to boot.   I can of course run
the installer with the kernel argument hdc=C,H,S with my values for
those aparameters, but I'm not sure if I will get a bootable system.

Has anyone ever seen anything like this on a Dell or any other
computer?  Is it likely to work if I proceed?  Where will grub put the
relevant pointer that is supposed to go in the MBR?

Were this a desktop computer,  I would open it up and check the
controller ports and the cables,  but I can't do that with a laptop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Start rescue CD
2.  Look at dev
3.   Run fdisk -l /dev/hdc
    

Actual Results:  Showed no /dev/hda

Expected Results:  Expected to find hda

Additional info:
Comment 1 Leonard Evens 2004-07-31 11:37:30 EDT
I've discovered that the machine has in addition to the primary and
secondary IDE controllers a PCI built-in ATA controller, which the
hard disk is presumably connected to.   That could be an explanation
for why the hard disk shows up as /dev/hdc.   In any case,  I still
would like to know if I am likely to encounter any dual boot
problems---keeping in mind the know bug in the installer---if I go
ahead with the installation using the kernel option  hdc=C,H,S.  Also,
are there any ongoing problems with ATA controllers in FC2?
Comment 2 Jeremy Katz 2004-08-01 13:23:46 EDT
bugzilla is not a support forum.  I've never seen anything like this
hardware-wise.  I don't think it's likely to cause problems but can't
really say for certain.

Note You need to log in before you can comment on or make changes to this bug.