Bug 1289148 - Pciutils built without libkmod suppport on CentOS 7
Pciutils built without libkmod suppport on CentOS 7
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pciutils (Show other bugs)
7.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Michal Hlavinka
William Gomeringer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 09:30 EST by David Shaughnessy
Modified: 2015-12-11 11:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 13:08:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shaughnessy 2015-12-07 09:30:45 EST
Build Identifier: 

The pciutils package is built without LIBKMOD=yes set in the Makefile. 
Because of this lspci is not reporting kernel modules compatible with the device.

This has been fixed on Fedora but still persists on CentOS 7.
previous bug: https://bugzilla.redhat.com/show_bug.cgi?id=1087862

Reproducible: Always

Steps to Reproduce:
1.run lspci -vs 0000:01:00.0
2.there is no "Kernel modules" line in the output
3.
Actual Results:  
01:00.0 PCI bridge: Intel Corporation C608/C606/X79 series chipset PCI Express Upstream Port (rev 06) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Memory at d1000000 (32-bit, non-prefetchable) [size=16K]
        Bus: primary=01, secondary=02, subordinate=03, sec-latency=0
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: d0f00000-d0ffffff
        Prefetchable memory behind bridge: 000038007f000000-000038007f9fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport


Expected Results:  
01:00.0 Class 0604: Device 8086:1d74 (rev 06)
        Flags: bus master, fast devsel, latency 0
        Memory at d1000000 (32-bit, non-prefetchable) [size=16K]
        Bus: primary=01, secondary=02, subordinate=03, sec-latency=0
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: d0f00000-d0ffffff
        Prefetchable memory behind bridge: 000038007f000000-000038007f9fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

Note You need to log in before you can comment on or make changes to this bug.