Bug 1289167 - Libtool requires: gcc = 5.1.1
Libtool requires: gcc = 5.1.1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 10:07 EST by Jakub Jelen
Modified: 2015-12-07 12:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:30:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelen 2015-12-07 10:07:58 EST
Description of problem:
After recent update of gcc to 5.2.1 and hitting stable mirrors I am unable to build package dependent on libtool because of broken dependencies.

Version-Release number of selected component (if applicable):
libtool-2.4.6-5.fc23.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. fedpkg clone opencryptoki
2. cd opencryptoki
3. git checkout f23
4. fedpkg scratch-build --arches=x86_64

Actual results (mock_output.log):
Error: Package: libtool-2.4.6-5.fc23.x86_64 (build)
           Requires: gcc = 5.1.1
           Installed: gcc-5.2.1-4.fc23.x86_64 (@build/$releasever)
               gcc = 5.2.1-4.fc23
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
pass build as in rawhide

Additional info:

Broken build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=12099181
Broken scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=12099549
Comment 1 Pavel Raiskup 2015-12-07 12:30:25 EST
It was temporary BuildOverride:
https://bodhi.fedoraproject.org/overrides/gcc-5.2.1-4.fc23

Note You need to log in before you can comment on or make changes to this bug.