Bug 1289178 - CFME 40 candidate is not instrumented to collect postgresql conf and log files in log collections
CFME 40 candidate is not instrumented to collect postgresql conf and log file...
Status: CLOSED DUPLICATE of bug 1272147
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
x86_64 Linux
high Severity medium
: GA
: 5.6.0
Assigned To: Nick Carboni
Oleksii Tsuman
appliance:maintenance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 10:29 EST by Thomas Hennessy
Modified: 2016-10-25 03:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 16:20:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-12-07 10:29:28 EST
Description of problem: postgresql configuration (*.conf), log file and logrotate log files are not collected by CFME log collection process


Version-Release number of selected component (if applicable):
5.5.0.13


How reproducible: very


Steps to Reproduce:
1. install an appliance
2. review vmdb.yml or any of the variants
3.

Actual results:
section from vmdb.yml.db"
=====
log:
  collection:
    :archive:
      :pattern: 
    :current:
      :pattern:
      - log/*.log
      - log/apache/*.log
      - log/*.txt
      - config/*
      - "/var/log/syslog*"
      - "/var/log/daemon.log*"
      - "/etc/default/ntp*"
      - "/var/log/messages*"
      - "/var/log/cron*"
      - BUILD
      - GUID
      - VERSION
    :ping_depot: true
    :ping_depot_timeout: 20
=====


Expected results: I expect to see the postgresql conf and log files in the pattern for collection.  these are located in 
 - '/var/opt/rh/rh-postgresql94/lib/pgsql/data/*.conf'
 - '/var/opt/rh/rh-postgresql94/lib/pgsql/data/pg_log/*'

respectively


Additional info:
Comment 2 Nick Carboni 2016-02-26 12:55:57 EST
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1272147

Can you confirm that the logs are indeed not being collected or is it just that the configuration changed location?
Comment 3 Thomas Hennessy 2016-02-26 15:56:25 EST
Nick,
In the past (evm thru cfme 5.4.x) the vmdb.yml configured list of 'collect' elements defined what was collected with the UI initiated log collection.  See current example from 5.5.2 appliance below:

=====
log:
  collection:
    :archive:
      :pattern: 
    :current:
      :pattern:
      - log/*.log
      - log/apache/*.log
      - log/*.txt
      - config/*
      - "/var/log/syslog*"
      - "/var/log/daemon.log*"
      - "/etc/default/ntp*"
      - "/var/log/messages*"
      - "/var/log/cron*"
      - BUILD
      - GUID
      - VERSION
=====

So in response to your question, since I have no good way to currently test ths as my testing appliances are all in Mahwah and Mahwah does not have connectivity to the Red Hat Dropbox I can only say:
1- yes the actual location of the logs has changed and changes apparently with each new major build (which is a real nuisance)
2- the postgresql logs are not indicated in the set of items reference above as the pattern for 'current' log collection
3- I have just performed a test on a 5.5.0.13 appliance with the configuration identified above (that is, lacking the postgresql file specifications) and see that the postgresql *.conf and log files (both *.log and logrotate files) are collected.

So while the BZ is accurate as reported, it appears that operationally a change has been made but not advertised (as far as I can tell) that postgresql information (configuration files and logs) will be collected withoug having to be specified in the log collection pattern.

Please confirm.
Comment 4 Nick Carboni 2016-02-26 16:20:35 EST
Correct, as stated in the BZ I referenced a change was made here (https://github.com/ManageIQ/manageiq/commit/31e0ffc693f80e80dbd97fc9b8306fa433236a1b) to use the environment variable $APPLIANCE_PG_DATA to determine the location of the postgresql logs for collection.

Closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 1272147 ***

Note You need to log in before you can comment on or make changes to this bug.