Bug 1289231 - [abrt] dnf: package.py:115:repo:KeyError: '@commandline'
[abrt] dnf: package.py:115:repo:KeyError: '@commandline'
Status: CLOSED DUPLICATE of bug 1226766
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:15d9aeacfb9f04094f6e1a02504...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 12:18 EST by Sudhir Khanger
Modified: 2016-04-07 06:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 06:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (543.24 KB, text/plain)
2015-12-07 12:18 EST, Sudhir Khanger
no flags Details
File: backtrace (1.24 KB, text/plain)
2015-12-07 12:18 EST, Sudhir Khanger
no flags Details
File: dnf-makecache.log (243.23 KB, text/plain)
2015-12-07 12:18 EST, Sudhir Khanger
no flags Details
File: environ (2.03 KB, text/plain)
2015-12-07 12:18 EST, Sudhir Khanger
no flags Details

  None (edit)
Description Sudhir Khanger 2015-12-07 12:18:20 EST
Version-Release number of selected component:
dnf-1.1.4-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /bin/dnf -y install --disablerepo=* /tmp/akmods.6NV44x4C/results/kmod-VirtualBox-4.2.6-301.fc23.x86_64-5.0.10-1.fc23.x86_64.rpm
executable:     /bin/dnf
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
package.py:115:repo:KeyError: '@commandline'

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 159, in resolving
    base.plugins.run_transaction()
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.4/site-packages/dnf-plugins/local.py", line 119, in transaction
    if pkg.repo.pkgdir == repodir:
  File "/usr/lib/python3.4/site-packages/dnf/package.py", line 115, in repo
    return self.base.repos[self.reponame]
KeyError: '@commandline'

Local variables in innermost frame:
self: <hawkey.Package object id 2252, kmod-VirtualBox-4.2.6-301.fc23.x86_64-5.0.10-1.fc23.x86_64, @commandline>
Comment 1 Sudhir Khanger 2015-12-07 12:18:36 EST
Created attachment 1103325 [details]
File: _var_log_dnf.log
Comment 2 Sudhir Khanger 2015-12-07 12:18:38 EST
Created attachment 1103326 [details]
File: backtrace
Comment 3 Sudhir Khanger 2015-12-07 12:18:45 EST
Created attachment 1103327 [details]
File: dnf-makecache.log
Comment 4 Sudhir Khanger 2015-12-07 12:18:47 EST
Created attachment 1103328 [details]
File: environ
Comment 5 Sudhir Khanger 2015-12-09 04:32:38 EST
This is even affecting normal package install.

$ sudo dnf reinstall google-chrome-unstable_current_x86_64.rpm
Last metadata expiration check performed 0:01:24 ago on Wed Dec  9 14:35:45 2015.
Dependencies resolved.
========================================================================================================================================================================
 Package                                         Arch                            Version                                    Repository                             Size
========================================================================================================================================================================
Reinstalling:
 google-chrome-unstable                          x86_64                          48.0.2564.22-1                             @commandline                           46 M

Transaction Summary
========================================================================================================================================================================

Total size: 46 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Reinstalling: google-chrome-unstable-48.0.2564.22-1.x86_64                                                                                                        1/2 
Redirecting to /bin/systemctl start  atd.service
  Erasing     : google-chrome-unstable-48.0.2564.22-1.x86_64                                                                                                        2/2 
  Verifying   : google-chrome-unstable-48.0.2564.22-1.x86_64                                                                                                        1/2 
  Verifying   : google-chrome-unstable-48.0.2564.22-1.x86_64                                                                                                        2/2 

Reinstalled:
  google-chrome-unstable.x86_64 48.0.2564.22-1                                                                                                                          

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 159, in resolving
    base.plugins.run_transaction()
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.4/site-packages/dnf-plugins/local.py", line 119, in transaction
    if pkg.repo.pkgdir == repodir:
  File "/usr/lib/python3.4/site-packages/dnf/package.py", line 115, in repo
    return self.base.repos[self.reponame]
KeyError: '@commandline'
Comment 6 Michal Luscon 2015-12-09 04:39:13 EST
You can try to disable plugins or uninstall plugin "local" as it looks like the local plugin is responsible for your issues.
Comment 7 Igor Gnatenko 2016-04-07 06:29:49 EDT

*** This bug has been marked as a duplicate of bug 1226766 ***

Note You need to log in before you can comment on or make changes to this bug.