Bug 128932 - usb-storage probe fails for USB memory drive
usb-storage probe fails for USB memory drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-31 17:11 EDT by Tom London
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-10 23:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2004-07-31 17:11:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
When I insert an 'M-Systems Flash Disk Pioneers DiskOnKey' USB memory
drive, the kernel produces the following, but fails to link the device
to /dev/sd1, etc.
 
Jul 31 12:21:46 fedora kernel: ohci_hcd 0000:00:03.2: wakeup
Jul 31 12:21:47 fedora kernel: usb 4-1: new full speed USB device
using address 2
Jul 31 12:21:47 fedora kernel: Initializing USB Mass Storage driver...
Jul 31 12:21:47 fedora kernel: usb-storage: probe of 4-1:1.0 failed
with error -1
Jul 31 12:21:47 fedora kernel: usbcore: registered new driver usb-storage
Jul 31 12:21:47 fedora kernel: USB Mass Storage support registered.

'lsusb' produces: 

Bus 004 Device 004: ID 08ec:0010 M-Systems Flash Disk Pioneers DiskOnKey
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 03f0:1e11 Hewlett-Packard
Bus 001 Device 002: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 0000:0000

but 'mount -t ext2 /dev/sda (or sda1) /mnt/dummy' produces
mount: /dev/sda (or /dev/sda1) is not a valid block address'

Works if I insert a USB-CDROM ....



Version-Release number of selected component (if applicable):
kernel-2.6.7-1.501 (and earlier)

How reproducible:
Always

Steps to Reproduce:
1. insert USB memory disk
2. try to mount
3.
    

Additional info:
Comment 1 Tom London 2004-08-01 18:29:52 EDT
Some additional info:

The USB drive is formatted with an EXT filesystem, and contains the
usual stuff needed to boot Linux.

If I leave the USB drive inserted during a power-on or reboot, the
BIOS recognizes it and boots from it without error, indicating that
there is nothing wrong with the drive.
Comment 2 Tom London 2004-08-05 11:50:54 EDT
Same behavior in .509
Comment 3 Tom London 2004-08-05 22:42:55 EDT
Ummmmm.... this is a bit curious.

Two other USB drives work just fine.

Sigh.  BIOS (and the brand X O/S) sees it fine, though...
Comment 4 Tom London 2004-08-23 23:34:12 EDT
Still fails in .526
Comment 5 Jeff Martin 2004-08-24 08:42:17 EDT
I'm having the same problems with a vfat formatted DiskOnkey. Works
fine with windows so I don't think it's the device.

Inserting the drive produces this in messages

usb 3-2.3: USB disconnect, address 8
usb 3-2.3: new full speed USB device using address 9
usb-storage: probe of 3-2.3:1.0 failed with error -1

I'm running 2.6.8-1.521

Used to work fine under fc1, not quite sure when it stopped.
Comment 6 Tom London 2004-09-06 14:42:49 EDT
running .541 in strict/permissive, seems to work!!
It even gets mounted as /media/usbdisk automagically.

Here are log messages (with AVC's deleted).

Since I can't boot into strict/enforcing, I can't test that yet.
When I can, I'll test and report.


Sep  6 11:36:13 fedora kernel: ohci_hcd 0000:00:03.2: wakeup
Sep  6 11:36:13 fedora kernel: usb 4-1: new full speed USB device
using address 5
Sep  6 11:36:13 fedora kernel: scsi3 : SCSI emulation for USB Mass
Storage devices
Sep  6 11:36:14 fedora kernel:   Vendor: M-Sys     Model: DiskOnKey  
      Rev: 2.50
Sep  6 11:36:14 fedora kernel:   Type:   Direct-Access               
      ANSI SCSI revision: 02
Sep  6 11:36:14 fedora kernel: SCSI device sda: 47104 512-byte hdwr
sectors (24 MB)
Sep  6 11:36:14 fedora kernel: sda: Write Protect is off
Sep  6 11:36:14 fedora kernel: sda: assuming drive cache: write through
Sep  6 11:36:14 fedora kernel:  sda: sda1
Sep  6 11:36:14 fedora kernel: Attached scsi removable disk sda at
scsi3, channel 0, id 0, lun 0
Sep  6 11:36:14 fedora scsi.agent[7640]: disk at
/devices/pci0000:00/0000:00:03.2/usb4/4-1/4-1:1.0/host3/3:0:0:0
Sep  6 11:36:15 fedora udev[7602]: creating device node '/dev/sda'
Sep  6 11:36:15 fedora udev[7614]: creating device node '/dev/sda1'
Sep  6 11:36:16 fedora last message repeated 4 times
Sep  6 11:36:16 fedora last message repeated 17 times
Sep  6 11:36:16 fedora fstab-sync[7702]: added mount point
/media/usbdisk for /dev/sda1
Sep  6 11:36:17 fedora kernel: SELinux: initialized (dev sda1, type
vfat), uses genfs_contexts

Comment 7 Tom London 2004-09-10 23:09:23 EDT
Cool.  Now works with .541 and strict/enforcing.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.