This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 128933 - php.conf file for httpd reports a syntax error
php.conf file for httpd reports a syntax error
Status: CLOSED DUPLICATE of bug 128854
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 01:39 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2004-08-01 01:39:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Trying to start httpd reports the following:

[root@tembo init.d]# ./httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: libcurl.so.2:
cannot open shared object file: No such file or directory
                                                           [FAILED]


Version-Release number of selected component (if applicable):
php-4.3.8-3

How reproducible:
Always

Steps to Reproduce:
1. install of rawhide/development of 2004-07-27
2. updates to 2004-07-30
3. start httpd
    

Actual Results:  [root@tembo init.d]# ./httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: libcurl.so.2:
cannot open shared object file: No such file or directory
                                                           [FAILED]


Expected Results:  httpd startup

Additional info:
Comment 1 Robert Scheck 2004-08-01 05:41:16 EDT
Requesting a rebuild of php-4.3.8-3 from Rawhide against current 
available curl-7.12.0-2 (also Rawhide) - which solves the problem, 
because:

--- snipp ---
# rpm -Uvh curl-* --test
error: Failed dependencies:
        libcurl.so.2 is needed by (installed) php-4.3.8-3
#
# rpm -qf `which /usr/lib/libcurl.so.2`
curl-7.11.1-1
# 
--- snapp ---
Comment 2 G.Wolfe Woodbury 2004-08-07 08:26:04 EDT
still present in rawhide install of 2004-08-06
Comment 3 Robert Scheck 2004-08-07 08:41:39 EDT
Joe, can we please get a rebuild of php in Rawhide soon? :)

*grmpf* I can't mark this bug as "EasyFix", so I do this here... :-(
Comment 4 Leonard den Ottolander 2004-08-07 09:38:06 EDT
This is actually a duplicate of bug 128854, which was filed under
curl. Since that bug is moved to php this one can be closed. I'll tag
the other bug EasyFix instead.


*** This bug has been marked as a duplicate of 128854 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.