Bug 1289351 - ardour4 won't start until passing `--no-hw-optimizations` option
ardour4 won't start until passing `--no-hw-optimizations` option
Status: CLOSED DUPLICATE of bug 1312551
Product: Fedora
Classification: Fedora
Component: ardour4 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 17:28 EST by fb.bugs.rh
Modified: 2016-03-04 03:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 03:49:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fb.bugs.rh 2015-12-07 17:28:48 EST
Description of problem:

After a fresh Fedora 23 WS 32-bit default netinstall with all updates, 
Ardour4 does not start.

Running `/usr/bin/ardour4` in a terminal gives the following error message:
```
Ardour4.4.0 (built using 4.4 and GCC version 5.1.1 20150618 (Red Hat 5.1.1-4))
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /etc/ardour4/system_config
CPU vendor: ntel�\X�ineI
Illegal instruction (core dumped)
```

Starting `ardour4` with `--no-hw-optimizations` option works.


Version-Release number of selected component (if applicable):

ardour4-4.4.0-1.fc23.i686.rpm
Ardour4.4.0 (built using 4.4 and GCC version 5.1.1 20150618 (Red Hat 5.1.1-4))


How reproducible:
Always until `--no-hw-optimizations` option is passed to `/usr/bin/ardour4`.


Steps to Reproduce:

In a terminal, do:

1. $ sudo dnf install ardour4
2. $ ardour4


Actual results:

Ardour4 does not start.


Expected results:

Ardour4 should start.


Additional info:

```
$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
model name	: Genuine Intel(R) CPU           T2080  @ 1.73GHz
stepping	: 12
microcode	: 0x59
cpu MHz		: 1064.000
cache size	: 1024 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts aperfmperf pni monitor est tm2 xtpr pdcm dtherm
bugs		:
bogomips	: 3458.15
clflush size	: 64
cache_alignment	: 64
address sizes	: 32 bits physical, 32 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
[...]

```

Ardour4 starts with `--no-hw-optimizations` option.
Comment 1 fb.bugs.rh 2015-12-08 16:38:08 EST
Ardour4 starts with `--no-hw-optimizations` option, but abort later just after the first time configuration screens:

[TERMINAL] 
$ ardour4 --no-hw-optimizations --debug all

[TERMINAL]  
WARNING: Your system has a limit for maximum amount of locked memory!
         This might cause Ardour to run out of memory before your system runs
         out of memory. You can view the memory limit with 'ulimit -l', and it
         is normally controlled by /etc/security/limits.conf

bind txt domain [gtk2_ardour4] to /usr/share/ardour4/locale
Ardour4.4.0 (built using 4.4 and GCC version 5.1.1 20150618 (Red Hat 5.1.1-4))
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /etc/ardour4/system_config
No H/W specific optimizations in use
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /etc/ardour4/default_ui_config
ardour: [INFO]: Loading color file /etc/ardour4/dark.colors
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
set default folder to /home/user


[GUI]  
'Welcome to Ardour' screen is displayed
nothing to do
> clic [Forward] button

'Default folder for new sessions' screen is displayed
select a default folder
> clic [Forward] button

'Monitoring  Choices' screen is displayed
leave untouched
> clic [Forward] button

'Monitor Section' screen is displayed
leave untouched
> clic [Forward] button

'Ardour is ready for use' screen is displayed
leave untouched
> clic [Apply] button


[TERMINAL]  
Found nothing along /home/user/.config/ardour4/templates:/usr/share/ardour4/templates
run dialog


[GUI]  
'Session Setup' window is displayed
Session name field filled with 'test'
> clic [Open] button

'Audio/MIDI Setup' window is displayed
Audio System: ALSA Stopped
> clic [Start] button
> clic [OK] button


[TERMINAL]  
Scanning folders for bundled LV2s: /usr/lib/ardour4/LV2
Set cursor set to default


[GUI]  
'Warning' window about limit for maximum amount of locked memory
> clic [OK] button

Then... nothing more.

[TERMINAL] 
Set cursor set to default
Skip explicit buffer seconds, preset in use
Skip explicit buffer seconds, preset in use
Set buffering params to 262144|131072|10|10

(ardour-4.4.0:1061): Gtk-CRITICAL **: gtk_text_buffer_emit_insert: assertion 'g_utf8_validate (text, len, NULL)' failed
Illegal instruction (core dumped)
[user@localhost ~]$ watched PID no longer exists - releasing device. ^C
[user@localhost ~]$



Then, restarting Ardour4 with `ardour4 --no-hw-optimizations --debug all` just shows:

[TERMINAL]
WARNING: Your system has a limit for maximum amount of locked memory!
         This might cause Ardour to run out of memory before your system runs
         out of memory. You can view the memory limit with 'ulimit -l', and it
         is normally controlled by /etc/security/limits.conf

bind txt domain [gtk2_ardour4] to /usr/share/ardour4/locale
Ardour4.4.0 (built using 4.4 and GCC version 5.1.1 20150618 (Red Hat 5.1.1-4))
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /etc/ardour4/system_config
Loading user configuration file /home/user/.config/ardour4/config
No H/W specific optimizations in use
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /etc/ardour4/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/user/.config/ardour4/ui_config
ardour: [INFO]: Loading color file /etc/ardour4/dark.colors
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
Found nothing along /home/user/.config/ardour4/templates:/usr/share/ardour4/templates
run dialog

[GUI]
The 'Session Setup', 'Audio/MIDI Setup' and 'Warning' windows are displayed.

Then... nothing more.

[TERMINAL]
Set cursor set to default
Skip explicit buffer seconds, preset in use
Skip explicit buffer seconds, preset in use
Set buffering params to 262144|131072|10|10

(ardour-4.4.0:3578): Gtk-CRITICAL **: gtk_text_buffer_emit_insert: assertion 'g_utf8_validate (text, len, NULL)' failed
Illegal instruction (core dumped)
[user@localhost ~]$ watched PID no longer exists - releasing device. ^C
[user@localhost ~]$


So, for now, Ardour4 is just unusable on my computer.
Comment 2 Nils Philippsen 2016-02-22 17:50:23 EST
Hi, I don't have real 32 bit hardware available for testing.

Running the program in a 32bit VM worked flawlessly for me, despite a similarly jumbled CPU vendor string.

Can you reproduce this error with the current version of ardour4, i.e. 4.7.0? I've just submitted it as a testing update here:

https://bodhi.fedoraproject.org/updates/FEDORA-2016-eb9c56ff0f

If so, can you generate a stack trace? The easiest way would be to install abrt and let it do the work for you, other ways are described here:

https://fedoraproject.org/wiki/StackTraces
Comment 3 Nils Philippsen 2016-03-04 03:49:18 EST
Hi, as Jérôme experiences the same issue and his bug contains stack traces etc., lets continue there. I'll close this bug as a duplicate of his.

*** This bug has been marked as a duplicate of bug 1312551 ***

Note You need to log in before you can comment on or make changes to this bug.