Bug 128938 - bash-3 and "trap"
bash-3 and "trap"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 06:24 EDT by Florian La Roche
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 3.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 11:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2004-08-01 06:24:41 EDT
Description of problem:

After updating to bash-3 a compile of OpenWrt fails due to
failing calls of "trap". Sorry, haven't looked what is missing
in detail, will update this buggzilla next round I do so.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2004-08-02 06:15:32 EDT
Is it related to this change?

http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00293.html
Comment 2 Florian La Roche 2004-08-02 06:24:51 EDT
Yes, excat same problem.
Comment 3 Tim Waugh 2004-08-17 11:46:27 EDT
I've made the usage string more helpful in 3.0-5.  OpenWrt should be
fixed to use 'trap - 0' in sh scripts.

Note You need to log in before you can comment on or make changes to this bug.