Bug 1289401 - add logging for qdrouterd service
add logging for qdrouterd service
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: 6.X
Assigned To: Stephen Benjamin
Katello QA List
https://github.com/Katello/puppet-qpi...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 21:10 EST by Chris Roberts
Modified: 2017-08-01 16:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:02:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16928 None None None 2016-10-14 07:14 EDT

  None (edit)
Description Chris Roberts 2015-12-07 21:10:25 EST
Description of problem:
By default qdrouterd does not have a stanza for logging. Please add logging for new installs

Version-Release number of selected component (if applicable):

6.1

Steps to Reproduce:
1. Install Satellite 6.1
2. try to view logs in /var/log directory

Actual results:
Nothing in /var/log for qdrouterd

Expected results:
qdrouterd to have a folder and logs inside to help diagnose connection issues

Additional info:

https://github.com/Katello/puppet-qpid/tree/master/templates/router

log {
    module: DEFAULT
    enable: debug+
    timestamp: true
    output: /var/log/qdrouterd.log
}
Comment 1 Chris Roberts 2015-12-07 21:11:08 EST
adding myself to the bug to create the patch
Comment 3 Stephen Benjamin 2016-01-15 15:17:47 EST
The qpid module supports it, we just need to add it to the capsule and katello installer modules to configure some sensible log level by default.  You'd configure it like the other fragments:

https://github.com/Katello/puppet-capsule/blob/master/manifests/dispatch_router.pp#L19
Comment 6 Bryan Kearney 2016-07-26 15:09:10 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 7 Stephen Benjamin 2016-10-14 07:14:15 EDT
Created redmine issue http://projects.theforeman.org/issues/16928 from this bug
Comment 8 Bryan Kearney 2016-10-14 14:13:36 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16928 has been resolved.
Comment 10 Bryan Kearney 2017-08-01 16:02:41 EDT
The fix to this bug will be delivered with release 6.3 of Satellite.

Note You need to log in before you can comment on or make changes to this bug.