Bug 128942 - Broken files in the named chroot environment
Broken files in the named chroot environment
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: caching-nameserver (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 12:20 EDT by Angelo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: bind-9.2.4rc6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 16:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angelo 2004-08-01 12:20:37 EDT
Description of problem:
in /var/named/chroot/etc/, named.conf and rndc.key are not pointing to
/etc/named.conf and /etc/rndc.key


Version-Release number of selected component (if applicable):
7.2-12

How reproducible:
Ever

Steps to Reproduce:
1. ls -l /var/named/chroot/etc/
  
Actual results:
Blank files

Expected results:
Hard links to /etc/named.conf and /etc/rndc.key
Comment 1 Angelo 2004-08-02 08:37:17 EDT
I forgot to say that if the /etc/named.conf and /etc/rndc.key as well
as the /var/named/ zone files aren't the same files on the chroot
environment, named can't be stopped and restarted because rndc isn't
working.

It can't even re-read the config files, if you want it do so without
stopping the service.

Another solution can be to put those files in the chroot environment
and then symlink those in /etc and /var/named, like this:

/etc/rndc.key -> /var/named/chroot/etc/rndc.key
/etc/named.conf -> /var/named/chroot/etc/named.conf
etc. etc.
Comment 2 Jason Vas Dias 2004-08-02 16:14:27 EDT
This was fixed in bind-9.2.4rc6-3 :
the /var/named/chroot/etc/{named.conf,rndc.key} 
files were getting created as blank files;
they are now always copied from /etc .
Perhaps they should be hardlinks; but some people
might want different configs for a chroot environment
than for the non-chroot environment.
Comment 3 John Flanagan 2004-12-21 14:52:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-568.html

Note You need to log in before you can comment on or make changes to this bug.