Bug 1289438 - Cant see selected language when only using keyboard down arrow to select language during the anaconda installation
Cant see selected language when only using keyboard down arrow to select lang...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 01:39 EST by fine.fan
Modified: 2016-02-08 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 10:15:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blue_highlight_bar_out_of_the_box (117.63 KB, image/png)
2015-12-08 01:39 EST, fine.fan
no flags Details
RHEL7.2_LanguageSelectionList_TopToBottom (2.59 MB, video/VirtualBoxVideoCapture)
2016-01-18 21:35 EST, fine.fan
no flags Details

  None (edit)
Description fine.fan 2015-12-08 01:39:17 EST
Created attachment 1103465 [details]
blue_highlight_bar_out_of_the_box

Description of problem:

During the anaconda GUI installation,when the install program starting showing welcome and let you select the language.Only use keyboard down arrow to select the language in the left middle box, there is a part of the list which I could not see the language is selected  in the left middle box (actually the blue highlight bar is out of the box ),but I got the language changing on the GUI when I still press down arrow.

Version-Release number of selected component (if applicable):
anaconda 21.48.22.56-1

How reproducible:
Every time

Steps to Reproduce:
1.Insert the install media into a bare machine
2.Only use keyboard down arrow or up arrow to select the language,when the welcome screen appear, and let you select the language.
3.Go through the language list

Actual results:
The blue highlight bar should always in the left middle box,and put the list going down as I press the down arrow.

Expected results:
The blue highlight bar go out of the box

Additional info:
Comment 1 David Shea 2015-12-09 07:54:27 EST
Reassigning to gtk3, since as far as I can tell anaconda is doing everything that it needs to. The left column is a GtkTreeView added directly to a GtkScrolledWindow (via glade), so there should be no need for manual focus vadjustment changes.
Comment 2 Matthias Clasen 2016-01-18 12:23:52 EST
If you use arrow keys to move the selection further down, does it disappear from view completely, or do the next rows get scrolled up far enough to show up partially ?
Comment 3 fine.fan 2016-01-18 21:35 EST
Created attachment 1116019 [details]
RHEL7.2_LanguageSelectionList_TopToBottom

VirtualBox Video Capture file , could be opend with firefox.
Comment 4 fine.fan 2016-01-18 21:37:02 EST
(In reply to Matthias Clasen from comment #2)
> If you use arrow keys to move the selection further down, does it disappear
> from view completely, or do the next rows get scrolled up far enough to show
> up partially ?

If I use arrow keys to move the selection further down, it does disappear from view completely.But when I go through the language list with an arrow button it will show up at some language and then disappear from view again.For more detial please refer to the " RHEL7.2_LanguageSelectionList_TopToBottom" attachment
Comment 5 Matthias Clasen 2016-01-19 10:09:18 EST
gtk3-demo as shipped in gtk3-3.14.13-16.el7 has a treeview in a scrolledwindow (the sidebar) that works as expected.

I think this needs to be debugged on the anaconda side a little further before concluding that "this is a gtk problem".
Comment 6 David Shea 2016-01-21 16:53:11 EST
Could this be caused the language changing as the selection changes? What else could cause an issue with the scroll adjustment?
Comment 7 Matthias Clasen 2016-01-22 10:34:36 EST
(In reply to David Shea from comment #6)
> Could this be caused the language changing as the selection changes? What
> else could cause an issue with the scroll adjustment?

I don't know what you do when the language changes (reconstruct the entire ui ?), but that sounds plausible.

I had occasion to play a bit with anaconda ui yesterday, and I noticed that the list scrolls a *little* when changing the selection, even after arrowing out of the visible range - it is just not enough to bring the selected row into visible range.
Comment 8 David Shea 2016-01-22 10:42:38 EST
(In reply to Matthias Clasen from comment #7)
> (In reply to David Shea from comment #6)
> > Could this be caused the language changing as the selection changes? What
> > else could cause an issue with the scroll adjustment?
> 
> I don't know what you do when the language changes (reconstruct the entire
> ui ?), but that sounds plausible.

When the language changes anaconda will repopulate the locale list, retranslate a handful of widgets (the "Welcome to..." "What language...", and beta warning GtkLabels, the labels on the quit and continue buttons, and the placeholder text in the "Type here to search" GtkEntry), and possibly change the UI direction.

One thing I notice is that if the language changes the height of the labels (for example, the switch from Assamese to Asturian), the height of the GtkGrid containing the two TreeViews will change.
Comment 9 Matthias Clasen 2016-01-22 12:20:34 EST
(In reply to David Shea from comment #8)
> (In reply to Matthias Clasen from comment #7)
> > (In reply to David Shea from comment #6)
> > > Could this be caused the language changing as the selection changes? What
> > > else could cause an issue with the scroll adjustment?
> > 
> > I don't know what you do when the language changes (reconstruct the entire
> > ui ?), but that sounds plausible.
> 
> When the language changes anaconda will repopulate the locale list,
> retranslate a handful of widgets (the "Welcome to..." "What language...",
> and beta warning GtkLabels, the labels on the quit and continue buttons, and
> the placeholder text in the "Type here to search" GtkEntry), and possibly
> change the UI direction.
> 

If you repopulate the locale list, that sounds like it is very likely to affect the selection - do you re-select the current locale after repopulating ? If so, I would recommend to explicitly scroll that row into view at the same time
Comment 10 David Shea 2016-01-22 12:46:02 EST
By locale list I mean the tree on the right side of the window. Changing the selection on the left tree does not change the data in the left tree. And we do select and scroll_to_cell the first item on the right side.
Comment 11 RHEL Product and Program Management 2016-02-08 10:15:57 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.