Bug 1289445 - Unable to import JBoss Fuse into inventory when using 64 bit java in jenkins environment
Unable to import JBoss Fuse into inventory when using 64 bit java in jenkins ...
Status: CLOSED DUPLICATE of bug 1382041
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.3.0
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
: Triaged
Depends On: 1382041
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 02:00 EST by Tomas Plevko
Modified: 2017-02-15 12:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-23 10:00:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of the debug log (8.97 KB, text/plain)
2015-12-08 02:00 EST, Tomas Plevko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker FUSEJON-123 Major Open Unable to import Fuse into inventory when using 64 bit java in jenkins environment 2017-12-04 10:18 EST

  None (edit)
Description Tomas Plevko 2015-12-08 02:00:47 EST
Created attachment 1103467 [details]
Part of the debug log

Description of problem:

I encountered an issue when working with 64 bit Javas in our Jenkins environment, when I was trying to import the JBoss Fuse 6.2.1. resource to JON. For some reason, the problem does not occur when I switch to 32 bit Java.
The debug log shows that the plugin is unable to extract the JMX service URL :

2015-12-07 06:25:45,522 DEBUG [ResourceDiscoveryComponent.invoker.daemon-1] (org.jbosson.plugins.fuse.JBossFuseContainerDiscoveryComponent)- Error when trying to discover Fuse Server process [ProcessScanResult: scan=[ProcessScan: query=[process|basename|match=^java.*,arg|-Dkaraf.home|match=.*,arg|-Dkaraf.base|match=.*,arg|*|match=org\.apache\.karaf\.(main|shell\.wrapper)\.Main], name=[null]], info=[process: pid=[17843], name=[/usr/lib/jvm/java-1.7.0-openjdk.x86_64/bin/java], ppid=[17801]]].

java.lang.RuntimeException: Failed to extract JMX service URL for process with PID [17843].

	at org.rhq.plugins.jmx.util.JvmUtility.extractJMXServiceURL(JvmUtility.java:93)

	at org.jbosson.plugins.fuse.FuseServerDiscoveryComponent.discoverResourceDetails(FuseServerDiscoveryComponent.java:291)

	at org.jbosson.plugins.fuse.FuseServerDiscoveryComponent.discoverResources(FuseServerDiscoveryComponent.java:95)

	at sun.reflect.GeneratedMethodAccessor42.invoke(Unknown Source)

	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

	at java.lang.reflect.Method.invoke(Method.java:606)

	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:305)

	at java.util.concurrent.FutureTask.run(FutureTask.java:262)

	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

	at java.lang.Thread.run(Thread.java:745)

Caused by: java.lang.NullPointerException

	at org.rhq.plugins.jmx.util.JvmUtility.attachToVirtualMachine(JvmUtility.java:107)

	at org.rhq.plugins.jmx.util.JvmUtility.extractJMXServiceURL(JvmUtility.java:76)

	... 10 more

2015-12-07 06:25:45,523 DEBUG [RHQ Agent Prompt Input Thread] (org.rhq.core.system.NativeSystemInfo)- Retrieving PIDs of all running processes...

2015-12-07 06:25:45,524 DEBUG [RHQ Agent Prompt Input Thread] (org.rhq.core.system.NativeSystemInfo)- Retrieval of 184 PIDs took 1 ms.



Before this exception occurs, there are multiple exceptions with cause: org.hyperic.sigar.SigarException: Numerical result out of range.:

2015-12-07 06:25:45,441 DEBUG [RHQ Agent Prompt Input Thread] (org.rhq.core.system.ProcessInfo)- Unexpected error occurred while looking up info for [<unknown>] process with pid [17801] - call to getProcCredName failed. Did the process die? Cause: org.hyperic.sigar.SigarException: Numerical result out of range

2015-12-07 06:25:45,442 DEBUG [RHQ Agent Prompt Input Thread] (org.rhq.core.system.ProcessInfo)- Unexpected error occurred while looking up info for [<unknown>] process with pid [17843] - call to getProcCredName failed. Did the process die? Cause: org.hyperic.sigar.SigarException: Numerical result out of range

2015-12-07 06:25:45,443 DEBUG [RHQ Agent Prompt Input Thread] (org.rhq.core.system.ProcessInfo)- Unexpected error occurred while looking up info for [<unknown>] process with pid [19584] - call to getProcCredName failed. Did the process die? Cause: org.hyperic.sigar.SigarException: Numerical result out of range

Maybe this is issue related to (I found, that RHQ plugins use sigar in version 1.6.5):
https://jira.hyperic.com/browse/SIGAR-231

A piece of the agent debug log is attached.


Version-Release number of selected component (if applicable):

Version of the JMX plugin is : rhq-jmx-plugin-4.12.0.JON330GA.jar
I was using the newest JON plugin pack for JBoss Fuse


How reproducible: Use machines from our middleware jenkins environment for running of JBoss Fuse and JON agent and try to import it into JON inventory.
Comment 1 Filip Brychta 2016-01-07 10:48:35 EST
What exact platform is this?
Comment 2 Tomas Plevko 2016-01-15 07:49:15 EST
This log comes from a RHEL 6.7 machine with java-1.7.0-openjdk.x86_64.
The problem occurred also on solaris machines and RHEL machines with different versions. The only common thing I noticed when I encountered this error was, that the machines were using 64 bit Java.
Comment 5 Michael Burman 2017-01-23 08:23:54 EST
To me this looks like a duplicate of BZ 1382041

Note You need to log in before you can comment on or make changes to this bug.