Bug 1289446 - [userinterface_public_566]Can not filter builds in the build chart correctly
[userinterface_public_566]Can not filter builds in the build chart correctly
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 02:10 EST by Yanping Zhang
Modified: 2016-05-12 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filter-2 (146.53 KB, image/png)
2015-12-08 02:12 EST, Yanping Zhang
no flags Details
filter-4 (153.56 KB, image/png)
2015-12-08 02:13 EST, Yanping Zhang
no flags Details
filter-5 (151.65 KB, image/png)
2015-12-08 02:13 EST, Yanping Zhang
no flags Details
overlap (150.55 KB, image/png)
2015-12-08 02:14 EST, Yanping Zhang
no flags Details

  None (edit)
Description Yanping Zhang 2015-12-08 02:10:20 EST
Description of problem:
When builds have different labels, and filter builds with label on web console, it can not show builds in build chart correctly.

Version-Release number of selected component (if applicable):
$ openshift version
openshift v1.1-366-g9db1116
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always

Steps to Reproduce:
1.Create app in project
$oc create -f origin/examples/sample-app/application-template-stibuild.json -n prozyp
$oc new-app ruby-helloworld-sample -n prozyp
2.Trigger several builds from web console, make the builds finish with different status,such as complete/failed/cancelled
3.Add different label for each build.
$ oc label build/ruby-sample-build-1 buildnumber=first -n prozyp
build "ruby-sample-build-1" labeled
$ oc label build/ruby-sample-build-2 buildnumber=second -n prozyp
build "ruby-sample-build-2" labeled
$ oc label build/ruby-sample-build-3 buildnumber=third -n prozyp
build "ruby-sample-build-3" labeled
$ oc label build/ruby-sample-build-4 buildnumber=forth -n prozyp
build "ruby-sample-build-4" labeled
$ oc label build/ruby-sample-build-5 buildnumber=fifth -n prozyp
build "ruby-sample-build-5" labeled
4.Filter builds using the added labels in step 3, check the builds in chart.

Actual results:
4.Builds are not correctly filtered in the chart. Refer to attachments.

Expected results:
4.Should show right builds when filtering.

Additional info:
After clear some filter, the word "Duration" maybe overlapped by the chart line sometime. Ex, after clear filter in attachment filter-2, the overlapping appears in attachment "overlap". This issue will disappear after refresh the page.
Comment 1 Yanping Zhang 2015-12-08 02:12 EST
Created attachment 1103468 [details]
filter-2
Comment 2 Yanping Zhang 2015-12-08 02:13 EST
Created attachment 1103469 [details]
filter-4
Comment 3 Yanping Zhang 2015-12-08 02:13 EST
Created attachment 1103470 [details]
filter-5
Comment 4 Yanping Zhang 2015-12-08 02:14 EST
Created attachment 1103471 [details]
overlap
Comment 5 Samuel Padgett 2015-12-08 09:12:44 EST
It looks like we're not clearing groups that no longer appear in the chart when calling  chart.load(), so failed and cancelled builds still show even if they don't match the filter.
Comment 6 Samuel Padgett 2015-12-08 09:33:40 EST
Yangping, can you open a separate bug for the overlapping label?
Comment 7 Samuel Padgett 2015-12-08 09:38:42 EST
https://github.com/openshift/origin/pull/6234
Comment 8 Yanping Zhang 2015-12-09 01:53:55 EST
Track the overlapping issue in this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1289843
Comment 9 Yanping Zhang 2015-12-09 22:26:36 EST
Verified on latest origin code:
openshift v1.1-393-g89eb2fc
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

Steps to verify:
1.Create app in project
2.Trigger several builds from web console, make the builds finish with different status
3.Add different label for each build.
4.Filter builds using the added labels in step 3, check the builds in chart.
Actual results:
4.Could show the filtered builds in chart correctly now.

The bug has been fixed, so move it to Verified.

Note You need to log in before you can comment on or make changes to this bug.