Bug 128947 - RFE: 'Basic' /etc/passwd causes 'pwck' errors
RFE: 'Basic' /etc/passwd causes 'pwck' errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcpdump (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 17:40 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 05:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-08-01 17:40:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
The out-of-the-box /etc/passwd file has problems, according to pwck:

[root@localhost root]# pwck
user adm: directory /var/adm does not exist
user news: directory /etc/news does not exist
user uucp: directory /var/spool/uucp does not exist
user gopher: directory /var/gopher does not exist
user ftp: directory /var/ftp does not exist
user pcap: directory /var/arpwatch does not exist
pwck: no changes

Probably a dupe of an old bug 53532, which I do not have permission to
reopen.
Comment 1 Bill Nottingham 2004-09-23 15:41:38 EDT
The first four are legacy and cannot be changed.

/var/ftp is created by vsftpd on install.

The pcap user is created by arpwatch; assigning there.
Comment 2 Harald Hoyer 2004-09-24 03:56:57 EDT
$ rpm -qf  /var/arpwatch
arpwatch-2.1a13-7

well, user pcap is created by arpwatch on install

assigning back
Comment 3 Bill Nottingham 2004-09-24 14:19:07 EDT
It's complaining about the home directory arpwatch puts in /etc/passwd
not existing. Either it's a arpwatch pre problem, or not-a-bug.
Comment 4 Harald Hoyer 2004-09-27 03:52:08 EDT
why is it in /etc/passwd prior to arpwatch installation anyway?
Comment 5 Need Real Name 2004-10-22 04:34:25 EDT
FC3t3 with latest rpms still has a passwd file that pwck doesn't like.
Comment 6 Need Real Name 2004-10-25 03:00:38 EDT
Surely pre-existing accounts shouldn't be necessary, since we have
 /usr/share/doc/setup-*/uidgid ?
Comment 7 Kir Kolyshkin 2005-06-16 04:53:31 EDT
pcap user is created by _either_ arpwatch or tcpdump; both packages have the
preinstall script doing useradd/groupadd for pcap.

Could it be (possibly unrelated) problem that neither arpwatch nor tcpdump
requires shadow-utils (which provides /usr/sbin/{user,group}add)?

Note You need to log in before you can comment on or make changes to this bug.