Bug 1289635 - Document discovery_remaster script URL in pxe-less discovery documentation
Document discovery_remaster script URL in pxe-less discovery documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
6.1.5
Unspecified Unspecified
medium Severity medium (vote)
: GA
: 6.2
Assigned To: Dan Macpherson
satellite-doc-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 11:01 EST by Sachin Ghai
Modified: 2016-08-16 20:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 20:26:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Ghai 2015-12-08 11:01:44 EST
We need to plan out to document discovery_remaster script's URL in pxe-less discovery documentation. This script is used as tool to generate a modified discovery ISO with some extra kernel options.

This can be downloaded from here:

https://github.com/theforeman/foreman-discovery-image/blob/master/aux/remaster/discovery-remaster
Comment 3 Dan Macpherson 2016-07-05 22:10:40 EDT
The remaster script has been included with new PXEless Discovery documentation in the new Provisioning Guide:

https://access.stage.redhat.com/documentation/en/red-hat-satellite/6.2-beta/provisioning-guide/#Provisioning_Bare_Metal_Hosts-Implementing_PXE-less_Discovery

Sachin, was this this content you were aiming to have documented? Any further additions required?
Comment 4 Sachin Ghai 2016-07-07 09:26:08 EDT
Thanks Dan, Could you please update docs as from where that script will be available to users. May be a pointer to its location on filesystem.

"The Satellite Server also provides a tool (discovery-remaster) to remaster the image to include these kernel parameters."

I think we can rephrase it like:

The foreman-discovery-image rpm provides a tool to remaster the image......

[root@qe-sat6-upgrade-rhel7 ~]# rpm -ql foreman-discovery-image
/usr/bin/discovery-remaster
/usr/share/foreman-discovery-image
/usr/share/foreman-discovery-image/foreman-discovery-image-3.1.1-14.iso
[root@qe-sat6-upgrade-rhel7 ~]#
Comment 5 Dan Macpherson 2016-07-07 22:49:00 EDT
Hi Sachin,

The script should be executable from anywhere since it's in /usr/bin/. Is there any specific reason to include the full path to the script? It seems a bit unnecessary to me.

- Dan
Comment 6 Andrew Dahms 2016-08-16 20:26:14 EDT
No response from reporter in over one month.

Closing.

Note You need to log in before you can comment on or make changes to this bug.