Bug 128967 - Exception raised with default config file
Exception raised with default config file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 129208 129934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 08:04 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:31:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rc-samba-cups-option.patch (404 bytes, text/plain)
2004-08-02 08:04 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2004-08-02 08:04:20 EDT
# redhat-config-samba
Traceback (most recent call last):
 File "/usr/share/redhat-config-samba/redhat-config-samba.py", line
20, in ?
   mainWindow.MainWindow(debug_flag)
 File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in __init__
   self.samba_data = sambaParser.SambaParser(self)
 File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in
__init__
   self.parseFile()
 File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in
parseFile
   token = self.createToken(line)
 File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in
createToken
   token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
value), self.parent)
 File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in __init__
   raise AttributeError, value
AttributeError: ('cups options', 'raw')

The following patch corrects the bug. Full-fledged support for this
option should be added as well.
Comment 1 Bastien Nocera 2004-08-02 08:04:51 EDT
Created attachment 102349 [details]
rc-samba-cups-option.patch
Comment 2 Nils Philippsen 2004-08-06 03:45:04 EDT
I've built an erratum for this and put it up at
http://people.redhat.com/nphilipp/BETA/redhat-config-samba/ until it
is available from RHN.

Bastien, please make a new RFE for fully-fledged support for this option.
Comment 3 Nils Philippsen 2004-08-06 03:47:01 EDT
*** Bug 129208 has been marked as a duplicate of this bug. ***
Comment 4 Vince Worthington 2004-08-10 09:34:49 EDT
The "cups options = raw" configuration statement in
/etc/samba/smb.conf can also be commented out, as a short-term workaround.
Comment 5 Nils Philippsen 2004-08-14 14:14:25 EDT
*** Bug 129934 has been marked as a duplicate of this bug. ***
Comment 6 John Flanagan 2004-09-02 01:31:36 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-422.html

Note You need to log in before you can comment on or make changes to this bug.