Bug 1289708 - Bad buildrequires for releases before el6
Bad buildrequires for releases before el6
Status: CLOSED CURRENTRELEASE
Product: Restraint
Classification: Community
Component: general (Show other bugs)
0.1.21
Unspecified Unspecified
unspecified Severity unspecified
: 0.1.22
: ---
Assigned To: Bill Peck
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 13:41 EST by Bill Peck
Modified: 2016-04-20 20:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 10:49:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2015-12-08 13:41:52 EST
Description of problem:
BuildRequires:  perl(Getopt::Long)}

Conflicts with the perl package on releases earlier than el6.

Version-Release number of selected component (if applicable):
0.1.21-2

How reproducible:
Everytime

Steps to Reproduce:
1. try and build srpm on el4
Comment 1 Dan Callaghan 2015-12-09 01:35:35 EST
Bill, the EL4 and EL5 builds seem to be fine in our Koji... what exact error are you seeing?
Comment 2 Dan Callaghan 2015-12-09 02:25:43 EST
Oh I guess because you already fixed it here:

http://gerrit.beaker-project.org/4529

:-)

A bit strange though, I wonder why the Jenkins job didn't fail back when I added that BuildRequires?

Note You need to log in before you can comment on or make changes to this bug.