Bug 128971 - gconftool-2 creates read-only shared config files
gconftool-2 creates read-only shared config files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 10:54 EDT by Michael Young
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 11:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2004-08-02 10:54:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6)
Gecko/20040116

Description of problem:
I am installing FC2 and then applying the updates, but I have noticed
that files in the /etc/gconf tree created or modified by other
packages after GConf2 has been upgraded are only readable by root,
which is wrong for global configuration files. This seems to
correspond to GConf2 being upgraded to version 2.6.0-7 though as I was
upgrading several packages in the same rpm session it is difficult to
be sure.
Comment 1 Mark McLoughlin 2004-08-04 04:38:53 EDT
What are the permissions on the /etc/gconf/gconf.xml.defaults directory?
Comment 2 Michael Young 2004-08-04 04:53:35 EDT
ls -dl /etc/gconf/gconf.xml.defaults  
drwxr-xr-x  6 root root 4096 Jul  2 10:58 /etc/gconf/gconf.xml.defaults
The problem seems specific to the new GConf2 - I downgraded it and
another package, and upgraded the package with the old GConf2, and the
permissions were right.
Comment 3 Mark McLoughlin 2004-08-04 05:06:58 EDT
So, what were the permissions on /etc/gconf/gconf.xml.defaults when
you had the new GConf2 installed?
Comment 4 Michael Young 2004-08-04 05:48:01 EDT
Okay. It looks like I was misdiagnosing the problem. What is important
is the umask of the session running rpm, and not the GConf2 version.
If root's umask is 077 when a package is installed the new files
created by gconftool-2 are only readable by root. I still think this
is broken behaviour.
Comment 5 Mark McLoughlin 2004-08-10 11:38:25 EDT
Thanks, I've fixed upstream now:

  http://bugzilla.gnome.org/show_bug.cgi?id=145041

We'll be pulling that fix in very shortly when we update to the next
release of GConf2 - it'll definitely be in FC3 anyway.

Note You need to log in before you can comment on or make changes to this bug.