Bug 1289843 - [userinterface_public_566]Word "Duration" is overlapped in build chart after add/clear filter
[userinterface_public_566]Word "Duration" is overlapped in build chart after ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 01:52 EST by Yanping Zhang
Modified: 2016-05-12 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add-filter-chart (157.88 KB, image/png)
2015-12-09 01:54 EST, Yanping Zhang
no flags Details
clear-filter-chart (150.55 KB, image/png)
2015-12-09 01:55 EST, Yanping Zhang
no flags Details
overlap-2 (157.96 KB, image/png)
2015-12-09 02:32 EST, Yanping Zhang
no flags Details

  None (edit)
Description Yanping Zhang 2015-12-09 01:52:50 EST
Description of problem:
On web console filter builds by label, then clear the filter, the word "Duration" will be overlapped in build chart. 

Version-Release number of selected component (if applicable):
openshift v1.1-374-gddcd987
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Sometimes

Steps to Reproduce:
1.Create app in project
$oc create -f origin/examples/sample-app/application-template-stibuild.json -n prozyp
$oc new-app ruby-helloworld-sample -n prozyp
2.Trigger several builds from web console, make the builds finish with different status,such as complete/failed/cancelled
3.Add different labels for each build.
4.Filter builds using the added labels in step 3, check the builds in chart.
5.Clear filters, check the build chart.

Actual results:
4.The word "Duration" is pushed beside the left border. Refer to attachment.
5.After clear the filter, the word "Duration" is overlapped in build chart. Refer to attachment.


Expected results:
4,5.The word in build chart should be displayed well.

Additional info:
Comment 1 Yanping Zhang 2015-12-09 01:54 EST
Created attachment 1103800 [details]
add-filter-chart
Comment 2 Yanping Zhang 2015-12-09 01:55 EST
Created attachment 1103801 [details]
clear-filter-chart
Comment 3 Yanping Zhang 2015-12-09 02:31:28 EST
The overlapping issue appears also after clicking on the small square status box under the “Build Number“ line. Refer to "overlap-2" attachment.
Comment 4 Yanping Zhang 2015-12-09 02:32 EST
Created attachment 1103805 [details]
overlap-2
Comment 5 Samuel Padgett 2015-12-09 09:08:55 EST
This looks like a c3.js bug, and we have the latest version. I could change the label so it's inside the axis, but that could cause the bar to overlap the label in some cases.
Comment 6 Samuel Padgett 2015-12-09 15:40:27 EST
https://github.com/openshift/origin/pull/6249
Comment 7 Yanping Zhang 2015-12-10 22:05:22 EST
Tested on latest origin code.
openshift v1.1-405-g4679093
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2
When add filter on the build page, the word "Duration" is displayed well beside the axis.
After clear filter, the overlapping issue appears sometimes as shown in attachment "clear-filter-chart".
Comment 8 Samuel Padgett 2015-12-22 09:10:06 EST
https://github.com/openshift/origin/pull/6460
Comment 9 Yanping Zhang 2015-12-23 01:16:06 EST
QE Will check the bug after the pull is merged.
Comment 10 Samuel Padgett 2015-12-23 12:20:30 EST
Thanks, merged to origin now.
Comment 11 Yanping Zhang 2015-12-23 23:37:18 EST
openshift v1.1-630-gb197d32
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2
Tested against latest origin code, the overlapping issue has been fixed, so move the bug to Verified.

Note You need to log in before you can comment on or make changes to this bug.