Bug 128995 - kernel hangs after floating-point assist faults
kernel hangs after floating-point assist faults
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Geoff Gustafson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 16:17 EDT by Gary Hade
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 16:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Hade 2004-08-02 16:17:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
We've seen the kernel hang twice while running stress tests on a two 
node IBM x455.  In both cases a series of "floating-point assist 
fault" messages had been previously written to the console.  It is 
not clear whether the hang is associated with the floating-point 
errors.  The following messages are from the most recent failure.

float_exp_log(17776): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17780): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17769): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17771): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17771): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17781): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17783): floating-point assist fault at ip 
200000000008f7b2
float_exp_log(17785): floating-point assist fault at ip 
200000000008f7b2


Version-Release number of selected component (if applicable):
kernel-2.4.21-18.EL

How reproducible:
Sometimes

Steps to Reproduce:
1. We encountered the problem while subjecting the system to heavy 
test load.
2.
3.
    

Actual Results:  kernel hang

Expected Results:  no kernel hang

Additional info:
Comment 1 Jason Baron 2005-03-09 23:03:36 EST
hmmm, there isn't much to go on here. Is it possible to get an
alt-sysrq-t at the time of the hang?
Comment 2 Ernie Petrides 2005-09-12 15:32:33 EDT
Gary, are you going to follow up on this at some point?
Comment 3 Gary Hade 2005-09-12 16:29:39 EDT
Ernie, thanks for pinging me on this.  I somehow missed Jason's 6 month old
request for more information.  One reason I neglected to respond was probably
due to the lack of subsequent problem occurrences that would have provided
reminders.  Since the problem was not reproducible this bug can be closed.

  

Note You need to log in before you can comment on or make changes to this bug.