Bug 1290000 - Unable to install redhat-certification-openstack package on RHOSP6
Unable to install redhat-certification-openstack package on RHOSP6
Status: CLOSED NOTABUG
Product: Red Hat OpenStack Certification Program
Classification: Red Hat
Component: rhoscts (Show other bugs)
6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neeti Dahiya
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 08:29 EST by Maniram Maplelabs
Modified: 2015-12-09 13:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 13:00:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maniram Maplelabs 2015-12-09 08:29:38 EST
Description of problem:
Installing redhat-certification-openstack has a dependency to openstack-tempest-kilo

[root@fab101-controller ~(keystone_admin)]# yum install redhat-certification-openstack
Loaded plugins: langpacks, priorities, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package redhat-certification-openstack.noarch 0:1.0.5-1.el7 will be installed
--> Processing Dependency: openstack-tempest-kilo for package: redhat-certification-openstack-1.0.5-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: redhat-certification-openstack-1.0.5-1.el7.noarch (rhel-7-server-cert-rpms)
           Requires: openstack-tempest-kilo
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: redhat-certification-openstack-1.0.5-1.el7.noarch (rhel-7-server-cert-rpms)
           Requires: openstack-tempest-kilo
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable): 6


How reproducible:


Steps to Reproduce:
1. yum install redhat-certification-openstack


Actual results:
Package should not have a dependency on openstack-tempest-kilo

Expected results:
Package should have a dependency on openstack-tempest-master
Comment 2 Suman Guha 2015-12-09 12:29:04 EST
Hi Maniram,

Have you installed "redhat-certification" package this is needs to be installed first incase you have not ? 

Looks like from the description required packages such as "openstack-tempest-kilo" is not installed. Kindly follow this section "certification prerequisites" https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform_Certification_Test_Suite/6/html/User_Guide/chap-Certification_Requirements.html#Certification_Prerequisites

You are required to download tempest https://access.redhat.com/downloads/content/rhel---7/x86_64/3889/openstack-tempest-master/2015.1.1-1.el7/noarch/fd431d51/package 

If you refer the certification prerequisites it says:
Run the following commands to install the packages on the system-under-test:

# yum install [path/to/downloaded/redhat-certification-openstack/rpm]
# yum install [path/to/downloaded/openstack-tempest-master/rpm]

Replace [path/to/downloaded/redhat-certification-openstack/rpm] and [path/to/downloaded/openstack-tempest-master/rpm] with the location where the redhat-certification-openstack rpm file and the openstack-tempest-master rpm file are saved on the system-under-test. 

 Run the following commands to ensure that the correct version(s) of the redhat-certification-openstack and openstack-tempest-master packages are installed on the system-under-test:

# rpm -qa redhat-certification-openstack

# rpm -qa openstack-tempest-master

The following output is displayed:
redhat-certification-openstack-1.0.0-1.el7.noarch
openstack-tempest-master-2015.1.1-1.el7.noarch 

After applying above if you face any further issue let us know, our engineering team will get back to you.

Regards,
Suman

(In reply to Maniram Maplelabs from comment #0)
> Description of problem:
> Installing redhat-certification-openstack has a dependency to
> openstack-tempest-kilo
> 
> [root@fab101-controller ~(keystone_admin)]# yum install
> redhat-certification-openstack
> Loaded plugins: langpacks, priorities, product-id, search-disabled-repos,
> subscription-manager
> Resolving Dependencies
> --> Running transaction check
> ---> Package redhat-certification-openstack.noarch 0:1.0.5-1.el7 will be
> installed
> --> Processing Dependency: openstack-tempest-kilo for package:
> redhat-certification-openstack-1.0.5-1.el7.noarch
> --> Finished Dependency Resolution
> Error: Package: redhat-certification-openstack-1.0.5-1.el7.noarch
> (rhel-7-server-cert-rpms)
>            Requires: openstack-tempest-kilo
> **********************************************************************
> yum can be configured to try to resolve such errors by temporarily enabling
> disabled repos and searching for missing dependencies.
> To enable this functionality please set 'notify_only=0' in
> /etc/yum/pluginconf.d/search-disabled-repos.conf
> **********************************************************************
> 
> Error: Package: redhat-certification-openstack-1.0.5-1.el7.noarch
> (rhel-7-server-cert-rpms)
>            Requires: openstack-tempest-kilo
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> 
> Version-Release number of selected component (if applicable): 6
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. yum install redhat-certification-openstack
> 
> 
> Actual results:
> Package should not have a dependency on openstack-tempest-kilo
> 
> Expected results:
> Package should have a dependency on openstack-tempest-master
Comment 3 Maniram Maplelabs 2015-12-09 13:00:37 EST
Thanks. It worked.

Note You need to log in before you can comment on or make changes to this bug.