Bug 129002 - Cannot set WEP key
Cannot set WEP key
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-network (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 17:31 EDT by Kevin Otte
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 13:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Otte 2004-08-02 17:31:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Setting the WEP key in the GUI does nothing.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.60-1

How reproducible:
Always

Steps to Reproduce:
1. Select a wireless interface, click Edit
2. Go to the Wireless Settings tab
3. Set the SSID to specified, entering the appropriate SSID
4. Enter the hex wep key
5. Save changes
6. Activate interface
    

Actual Results:  Associated to a nearby non-WEP access point with a
different ESSID

Expected Results:  Should have associated to the network with the
given ESSID and WEP key.

Additional info:
Comment 1 Kevin Otte 2004-08-04 10:39:12 EDT
My test machine is using a Cisco Aironet 350.  Apparently the Cisco
driver writes a file called /etc/eth1.cfg which overrides the settings
made by redhat-config-network.  When this file is removed, it is
created again the next time the interface is brought up and the SSID
(and possibly the WEP key?) is recorded in that file.
Comment 2 Harald Hoyer 2004-08-31 07:31:58 EDT
the cisco driver writes this file??? is this driver in our standard
kernel?
the key used by the initscripts should be in any of
/etc/sysconfig/network-scripts/*key*

if the driver wants its own configuration file, well, then I cannot do
anything about it, besides changing the driver not to do so.
Comment 3 Kevin Otte 2004-09-22 13:01:33 EDT
Turns out I had an /sbin/ifup-pre-local file doing some crazy stuff.

The eventual goal was to use different ESSID and WEP keys with
different profiles, but those design issues are probably outside the
scope of this bug.

Note You need to log in before you can comment on or make changes to this bug.