Bug 1290057 - VPN connections fail
VPN connections fail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 10:13 EST by Tim Waugh
Modified: 2016-10-29 07:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-29 07:48:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2015-12-09 10:13:01 EST
Description of problem:
Starting with NetworkManager-1.0.6-8.fc23, VPN connections fail like this:

Dec 09 15:00:30 river nm-openvpn[4357]: UDPv4 link local: [undef]
Dec 09 15:00:30 river nm-openvpn[4357]: UDPv4 link remote: [AF_INET]x.x.x.x:443
Dec 09 15:00:39 river nm-openvpn[4357]: [xxx.xxx.xxx] Peer Connection Initiated with [AF_INET]x.x.x.x:443
Dec 09 15:00:41 river nm-openvpn[4357]: TUN/TAP device tun0 opened
Dec 09 15:00:41 river nm-openvpn[4357]: /usr/libexec/nm-openvpn-service-openvpn-helper --tun -- tun0 1360 1417   init
Dec 09 15:00:41 river NetworkManager[1363]: <info>  (tun0): new Tun device (carrier: OFF, driver: 'tun', ifindex: 11)
Dec 09 15:00:41 river NetworkManager[1363]: <info>  VPN connection 'XXX XXX XXX' (IP Config Get) reply received.
Dec 09 15:00:41 river NetworkManager[1363]: <info>  VPN connection 'XXX XXX XXX' (IP4 Config Get) reply received.
Dec 09 15:00:41 river NetworkManager[1363]: <error> [1449673241.543061] [vpn-manager/nm-vpn-connection.c:1304] nm_vpn_connection_ip4_config_get(): invalid IP4 config received!
Dec 09 15:00:41 river NetworkManager[1363]: <warn>  VPN connection 'XXX XXX XXX' did not receive valid IP config information.

Downgrading to 1.0.6-6 gives:

Dec 09 15:03:41 river nm-openvpn[4880]: UDPv4 link local: [undef]
Dec 09 15:03:41 river nm-openvpn[4880]: UDPv4 link remote: [AF_INET]x.x.x.x:443
Dec 09 15:03:45 river nm-openvpn[4880]: [ovpn-phx2.redhat.com] Peer Connection Initiated with [AF_INET]x.x.x.x:443
Dec 09 15:03:47 river nm-openvpn[4880]: TUN/TAP device tun0 opened
Dec 09 15:03:47 river nm-openvpn[4880]: /usr/libexec/nm-openvpn-service-openvpn-helper --tun -- tun0 1360 1417 x.x.x.x 255.255.255.0 init
[...]

Version-Release number of selected component (if applicable):
NetworkManager-1.0.6-6.fc23.x86_64

How reproducible:
100%
Comment 1 Cole Robinson 2015-12-09 10:51:19 EST
Same exact problem: 1.0.6-8 fails, downgrading to 10.0.6-6 works
Comment 2 Jirka Klimes 2015-12-11 04:02:44 EST
Would you update to latest stable release 1.0.8, I guess it may be fixed there.

Else, you can try this scratch-build containing the latest snapshot of nm-1-0 branch (basically what will become 1.0.10):
http://koji.fedoraproject.org/koji/taskinfo?taskID=12148502
Comment 3 Tim Waugh 2015-12-18 17:58:34 EST
Seems to be fixed in NetworkManager-1.0.8-1.fc23.x86_64.

Note You need to log in before you can comment on or make changes to this bug.