Bug 1290108 - Yum Extender (DNF) shows update for uninstalled Perl package.
Yum Extender (DNF) shows update for uninstalled Perl package.
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 1288771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 11:43 EST by mike.winter
Modified: 2016-12-20 11:50 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:50:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf-bug 1288771 (closed) (738.10 KB, application/x-gzip)
2015-12-15 09:26 EST, Jxanti.jx
no flags Details

  None (edit)
Description mike.winter 2015-12-09 11:43:29 EST
DNF update shows 'perl-Unicode-Normalize-1.24-1.fc23.x86_64' as a suggested update but the update fails if selected. Error in journal is "org.baseurl.DnfSystem[892]: Package perl-Unicode-Normalize not installed, cannot update it."



Version-Release number of selected component (if applicable): 1.1.4


How reproducible: Unsure. 


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Mracek 2015-12-14 07:38:20 EST
Please, could you provide additional information. What exactly you executed and what was output. Please could you check if package is installed by: rpm -q perl-Unicode-Normalize
Thanks a lot
Comment 2 mike.winter 2015-12-14 09:46:46 EST
Hi Jaroslav, this package came up in the suggested upgrades in yumex-dnf.

rpm version:

perl-Unicode-Normalize-1.21-1.fc23.noarch

An architecture mismatch?
Comment 3 Honza Silhan 2015-12-14 11:48:44 EST
*** Bug 1288771 has been marked as a duplicate of this bug. ***
Comment 4 Honza Silhan 2015-12-14 11:51:31 EST
As there are two reports for yumex-dnf and not for dnf I am changing the component. Does `dnf update` from command line works for you?
Comment 5 mike.winter 2015-12-14 11:55:09 EST
Yes, dnf update worked and the 1.24.1 package was installed successfully.
Comment 6 Tim Lauridsen 2015-12-15 06:37:59 EST
I have seen it before, that yumex-dnf show some perl updates that could not be applied. 

What version of yumex-dnf & dnfdaemon are you using ?
Comment 7 Jxanti.jx 2015-12-15 09:26 EST
Created attachment 1106043 [details]
dnf-bug 1288771 (closed)
Comment 8 Jxanti.jx 2015-12-15 09:36:47 EST
(In reply to Jaroslav Mracek from comment #3)
> Please use command dnf group install <groupname>.
> If you will experience further problem, please provide us additional
> information with commands and their output. Also please provide dnf version.
> Than we can reproduce it and fix it.

I did a new install of F23Mate and gathered some information as dnf version
and content of dnf.log (the same before trying to update packages via dnf and
after the bug.
See the screen shots (dnf-bug 1288771-info .tar.gz)

I do not know what to do with installing groups. This is new for me.
So I tried to update packages as you see in the attachments in 
dnf-bug 1288771-info .tar.gz

I saw my bug has been CLOSED but I like to answer Jaroslav Mracek because he
asked for.

=====The above is actually not a problem for me because I can do the first
update via old yumex

If you propose using a new dnf version of some solution for Perl I can understand
that helps but I like an automatic update before I start updating with dnf.
Comment 9 mike.winter 2015-12-15 14:45:43 EST
yumex-dnf: 4.1.5-1.fc23

dnf: 1.1.4-2.fc23
Comment 10 Petr Pisar 2016-04-25 03:28:22 EDT
Some anonymous users complained about "Error(s) in building transaction update" in the perl-Unicode-Normalize-1.24-1.fc23 update <https://bodhi.fedoraproject.org/updates/FEDORA-2015-adcf83cb70>.

I cannot see what could be wrong with the RPM package. The only unusual feature is it conflicts with some older perl package.
Comment 11 Fedora End Of Life 2016-11-24 09:06:19 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2016-12-20 11:50:28 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.