Bug 1290113 - [gobject-introspection] prevents firewalld from starting up
[gobject-introspection] prevents firewalld from starting up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gobject-introspection (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 11:46 EST by Joachim Frieben
Modified: 2015-12-12 11:03 EST (History)
4 users (show)

See Also:
Fixed In Version: gobject-introspection-1.47.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 11:03:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-12-09 11:46:53 EST
Description of problem:
For the current Fedora development tree, selinux-policy-targeted prevents firewalld from starting up.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-162.fc24

How reproducible:
Always

Steps to Reproduce:
1. Boot system running the current Fedora development tree.

Actual results:
firewalld fails to start up.

Expected results:
firewalld starts up as expected.

Additional information:
::::::::::::::
enforcing=1
::::::::::::::
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2015-12-09 18:12:11 CET; 1min 9s ago
  Process: 796 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=1/FAILURE)
 Main PID: 796 (code=exited, status=1/FAILURE)

Dec 09 18:12:04 localhost systemd[1]: Starting firewalld - dynamic firewall daemon...
Dec 09 18:12:11 rlocalhost systemd[1]: firewalld.service: Main process exited, code=exited, status=1/FAILURE
Dec 09 18:12:11 localhost systemd[1]: Failed to start firewalld - dynamic firewall daemon.
Dec 09 18:12:11 localhost systemd[1]: firewalld.service: Unit entered failed state.
Dec 09 18:12:11 localhost systemd[1]: firewalld.service: Failed with result 'exit-code'.
::::::::::::::
enforcing=0
::::::::::::::
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2015-12-09 18:19:38 CET; 54s ago
 Main PID: 823 (firewalld)
    Tasks: 2 (limit: 512)
   CGroup: /system.slice/firewalld.service
           └─823 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

Dec 09 18:19:31 localhost systemd[1]: Starting firewalld - dynamic firewall daemon...
Dec 09 18:19:38 localhost systemd[1]: Started firewalld - dynamic firewall daemon.
Dec 09 18:20:14 localhost systemd[1]: Started firewalld - dynamic firewall daemon.
Comment 1 Joachim Frieben 2015-12-12 11:03:01 EST
Issue can be traced back to component gobject-introspection: for the current Fedora development tree in enforcing mode, the issue reappears if and only if the system is downgraded to gobject-introspection-1.47.1-1.fc24 whereas on a fully updated system including gobject-introspection-1.47.1-2.fc24, service firewalld starts up as expected.

Note You need to log in before you can comment on or make changes to this bug.