Bug 1290129 - pvs +pv_tags segfault while actively adding and removing tags
pvs +pv_tags segfault while actively adding and removing tags
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Peter Rajnoha
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 12:24 EST by Corey Marthaler
Modified: 2016-06-06 15:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 15:25:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2015-12-09 12:24:01 EST
Description of problem:
Not much to go on here until I can get a core to go along with this.

[root@mckinley-02 ~]# pvs -a -o +pv_tags
  WARNING: Volume Group cache_sanity is not consistent.
  Volume group "cache_sanity" not found
  Cannot process volume group cache_sanity
  PV                         VG               Fmt  Attr PSize   PFree  PV Tags
  /dev/mapper/mpatha1                              ---       0      0         
  /dev/mapper/mpathb1                              ---       0      0         
  /dev/mapper/mpathc1                              ---       0      0         
  /dev/mapper/mpathd1                              ---       0      0         
  /dev/mapper/mpathe1                              ---       0      0         
  /dev/mapper/mpathf1                              ---       0      0         
  /dev/mapper/mpathg1                              ---       0      0         
  /dev/mapper/mpathh1                              ---       0      0         
  /dev/rhel_mckinley-02/home                       ---       0      0         
  /dev/rhel_mckinley-02/root                       ---       0      0         
  /dev/rhel_mckinley-02/swap                       ---       0      0         
  /dev/sda1                                        ---       0      0         
  /dev/sda2                  rhel_mckinley-02 lvm2 a--  278.97g 60.00m        
  /dev/sdb1                  rhel_mckinley-02 lvm2 a--  279.46g     0         

[root@mckinley-02 ~]# pvs -a -o +pv_tags
Segmentation fault

[154550.380792] traps: pvs[62411] general protection ip:7fccf53238ed sp:7ffd06e267c8 error:0 in lvm[7fccf52b0000+168000]

[root@mckinley-02 ~]# pvs -a -o +pv_tags
  PV                         VG               Fmt  Attr PSize   PFree   PV Tags
  /dev/mapper/mpatha1        cache_sanity     lvm2 a--  249.99g 249.99g        
  /dev/mapper/mpathb1        cache_sanity     lvm2 a--  249.99g 249.99g fast   
  /dev/mapper/mpathc1        cache_sanity     lvm2 a--  249.99g 249.99g slow   
  /dev/mapper/mpathd1                              ---       0       0         
  /dev/mapper/mpathe1        cache_sanity     lvm2 a--  249.99g 249.99g        
  /dev/mapper/mpathf1                              ---       0       0         
  /dev/mapper/mpathg1                              ---       0       0         
  /dev/mapper/mpathh1                              ---       0       0         
  /dev/rhel_mckinley-02/home                       ---       0       0         
  /dev/rhel_mckinley-02/root                       ---       0       0         
  /dev/rhel_mckinley-02/swap                       ---       0       0         
  /dev/sda1                                        ---       0       0         
  /dev/sda2                  rhel_mckinley-02 lvm2 a--  278.97g  60.00m        
  /dev/sdb1                  rhel_mckinley-02 lvm2 a--  279.46g      0         


Version-Release number of selected component (if applicable):
3.10.0-325.el7.x86_64
lvm2-2.02.130-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
lvm2-libs-2.02.130-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
lvm2-cluster-2.02.130-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
device-mapper-1.02.107-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
device-mapper-libs-1.02.107-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
device-mapper-event-1.02.107-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
device-mapper-event-libs-1.02.107-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
device-mapper-persistent-data-0.5.5-1.el7    BUILT: Thu Aug 13 09:58:10 CDT 2015
cmirror-2.02.130-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
sanlock-3.2.4-1.el7    BUILT: Fri Jun 19 12:48:49 CDT 2015
sanlock-lib-3.2.4-1.el7    BUILT: Fri Jun 19 12:48:49 CDT 2015
lvm2-lockd-2.02.130-5.el7    BUILT: Wed Oct 14 08:27:29 CDT 2015
Comment 1 Corey Marthaler 2015-12-09 17:38:44 EST
Core was generated by `pvs -a -o +pv_tags'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f3ad77cd8ed in dev_name (dev=0x7f3ad7c70610) at device/dev-cache.c:1115
1115            return (dev && dev->aliases.n) ? dm_list_item(dev->aliases.n, struct dm_str_list)->str :
Missing separate debuginfos, use: debuginfo-install bzip2-libs-1.0.6-13.el7.x86_64 elfutils-libelf-0.163-3.el7.x86_64 elfutils-libs-0.163-3.el7.x86_64 glibc-2.17-105.el7.x86_64 libattr-2.4.46-12.el7.x86_64 libblkid-2.23.2-26.el7.x86_64 libcap-2.22-8.el7.x86_64 libgcc-4.8.5-4.el7.x86_64 libselinux-2.2.2-6.el7.x86_64 libsepol-2.1.9-3.el7.x86_64 libuuid-2.23.2-26.el7.x86_64 ncurses-libs-5.9-13.20130511.el7.x86_64 pcre-8.32-15.el7.x86_64 readline-6.2-9.el7.x86_64 systemd-libs-219-19.el7.x86_64 xz-libs-5.1.2-12alpha.el7.x86_64 zlib-1.2.7-15.el7.x86_64
(gdb) bt
#0  0x00007f3ad77cd8ed in dev_name (dev=0x7f3ad7c70610) at device/dev-cache.c:1115
#1  0x00007f3ad7808651 in _vg_read_orphan_pv (info=<optimized out>, baton=0x7ffc3268a510) at metadata/metadata.c:3272
#2  0x00007f3ad77c0e31 in lvmcache_foreach_pv (vginfo=vginfo@entry=0x7f3ad7c458d0, fun=fun@entry=0x7f3ad7808610 <_vg_read_orphan_pv>, 
    baton=baton@entry=0x7ffc3268a510) at cache/lvmcache.c:2206
#3  0x00007f3ad780bcd4 in _vg_read_orphans (orphan_vgname=0x7f3ad7c3fbd8 "P\376\303\327:\177", warn_flags=3, cmd=0x7f3ad7c0c020) at metadata/metadata.c:3333
#4  _vg_read (cmd=cmd@entry=0x7f3ad7c0c020, vgname=vgname@entry=0x7f3ad7c55cf2 "#orphans_lvm2", vgid=vgid@entry=0x7f3ad7c55ce2 "#orphans_lvm2", 
    warn_flags=warn_flags@entry=3, consistent=consistent@entry=0x7ffc3268a600, precommitted=precommitted@entry=0) at metadata/metadata.c:3529
#5  0x00007f3ad780cf3f in vg_read_internal (cmd=cmd@entry=0x7f3ad7c0c020, vgname=vgname@entry=0x7f3ad7c55cf2 "#orphans_lvm2", 
    vgid=vgid@entry=0x7f3ad7c55ce2 "#orphans_lvm2", warn_flags=warn_flags@entry=3, consistent=consistent@entry=0x7ffc3268a600) at metadata/metadata.c:3979
#6  0x00007f3ad780e6cb in _vg_lock_and_read (lockd_state=0, misc_flags=0, status_flags=0, lock_flags=33, vgid=0x7f3ad7c55ce2 "#orphans_lvm2", 
    vg_name=0x7f3ad7c55cf2 "#orphans_lvm2", cmd=0x7f3ad7c0c020) at metadata/metadata.c:4973
#7  vg_read (cmd=cmd@entry=0x7f3ad7c0c020, vg_name=vg_name@entry=0x7f3ad7c55cf2 "#orphans_lvm2", vgid=0x7f3ad7c55ce2 "#orphans_lvm2", flags=flags@entry=524288, 
    lockd_state=0) at metadata/metadata.c:5072
#8  0x00007f3ad77ac1da in _process_pvs_in_vgs (process_single_pv=0x7f3ad77a4480 <_pvs_single>, handle=0x7ffc3268a940, process_all_devices=1, process_all_pvs=1, 
    arg_tags=0x7ffc3268a720, arg_devices=0x7ffc3268a740, all_devices=0x7ffc3268a760, all_vgnameids=0x7ffc3268a750, flags=0, cmd=0x7f3ad7c0c020) at toollib.c:2928
#9  process_each_pv (cmd=cmd@entry=0x7f3ad7c0c020, argc=argc@entry=0, argv=argv@entry=0x7ffc3268aca8, only_this_vgname=only_this_vgname@entry=0x0, 
    flags=flags@entry=0, handle=handle@entry=0x7ffc3268a940, process_single_pv=<optimized out>) at toollib.c:3039
#10 0x00007f3ad77a5652 in _report (cmd=0x7f3ad7c0c020, argc=0, argv=<optimized out>, report_type=PVS) at reporter.c:808
#11 0x00007f3ad779a388 in lvm_run_command (cmd=cmd@entry=0x7f3ad7c0c020, argc=0, argc@entry=4, argv=0x7ffc3268aca8, argv@entry=0x7ffc3268ac88) at lvmcmdline.c:1655
#12 0x00007f3ad779adf0 in lvm2_main (argc=4, argv=0x7ffc3268ac88) at lvmcmdline.c:2121
#13 0x00007f3ad64a6b15 in __libc_start_main () from /lib64/libc.so.6
#14 0x00007f3ad7781df1 in _start ()
Comment 2 Peter Rajnoha 2016-06-06 07:32:20 EDT
Is this still reproducible with current 7.3 build lvm2-2.02.152-2.el7? If yes, I'd need to know what are the steps to reproduce - how was the VG made inconsistent?
Comment 3 Corey Marthaler 2016-06-06 15:25:19 EDT
No, I was unable to reproduce this with the latest rpms.


3.10.0-419.el7.x86_64
lvm2-2.02.152-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
lvm2-libs-2.02.152-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
lvm2-cluster-2.02.152-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
device-mapper-1.02.124-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
device-mapper-libs-1.02.124-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
device-mapper-event-1.02.124-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
device-mapper-event-libs-1.02.124-2.el7    BUILT: Thu May  5 02:33:28 CDT 2016
device-mapper-persistent-data-0.6.2-0.1.rc8.el7    BUILT: Wed May  4 02:56:34 CDT 2016

Note You need to log in before you can comment on or make changes to this bug.