Bug 1290222 - replicators: when no events exists for the replicators the timeline button becomes greyed out
replicators: when no events exists for the replicators the timeline button be...
Status: CLOSED DEFERRED
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity high
: GA
: 5.5.2
Assigned To: Dan Clarizio
Dave Johnson
container
: ZStream
Depends On: 1287827
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 16:21 EST by John Prause
Modified: 2015-12-10 16:40 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287827
Environment:
Last Closed: 2015-12-10 16:40:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Prause 2015-12-09 16:21:13 EST
+++ This bug was initially created as a clone of Bug #1287827 +++

Description of problem:

This only happens to replicators and not to pods/containers. 
However, I think it's wrong behaviour and that the button should always be available and if no events exists simply say that in the query. 
 
Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create a replicator and delete the event from db or... add an existing openshift provider with a very old replicator running which no longer has any events on it
2. navigate to containers -> replicator
3. select the relicator -> monitoring -> timeline

Actual results:

timeline is greyed out

Expected results:

timeline should not be greyed out but we should be able to select it and get a message that no events exists for the replicator

Additional info: screen shot and logs attached

http://pastebin.test.redhat.com/332347

--- Additional comment from Harpreet Kataria on 2015-12-02 15:06:21 EST ---

Dafna,

That is the correct behavior across UI to disable/grey out Timelines button when there are no events available for an object.
I think this is not an issue, so the BZ should be closed.

Thanks,
~Harpreet

--- Additional comment from Dafna Ron on 2015-12-03 04:30:41 EST ---

honestly I think that current behaviour looks like a bug which is why I opened it :) I think it's much better to allow selection and report that no events exist for the object. 
I understand that this is the current agreed behaviour but speaking from a user prospective I think it should be changed and do not think this bug should be closed. 
Having said that, I have no objections to change this to an RFE so it could be discussed in future.

--- Additional comment from Harpreet Kataria on 2015-12-04 10:30:02 EST ---

Dafna,

I think this should be changed to RFE, since that's the existing behavior for all Timelines buttons across the UI.

Thanks,
~Harpreet

--- Additional comment from Dafna Ron on 2015-12-07 05:57:24 EST ---

(In reply to Harpreet Kataria from comment #3)
> Dafna,
> 
> I think this should be changed to RFE, since that's the existing behavior
> for all Timelines buttons across the UI.
> 
> Thanks,
> ~Harpreet

Agreed.
We do not have an RFE component so I am not sure how to do that.

Note You need to log in before you can comment on or make changes to this bug.