This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290226 - [Director] overcloud systems are not registered to RHSM during deployment
[Director] overcloud systems are not registered to RHSM during deployment
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity high
: y2
: 7.0 (Kilo)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation, Reopened, ZStream
Depends On: 1290042
Blocks: 1290377
  Show dependency treegraph
 
Reported: 2015-12-09 16:24 EST by chris alfonso
Modified: 2016-02-29 20:32 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290042
Environment:
Last Closed: 2016-02-29 20:32:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Jon Thomas 2016-01-28 10:07:17 EST
hi

Its only during the update and is related to usage of overcloud-resource-registry-puppet.yaml. Including this in the update command causes the problem. 

but if you remove it (as below), the update works as expected:

$ openstack overcloud update stack osp72r1 -i --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml -e ~/templates/storage-environment.yaml  -e ~/templates/pre-deployment.yaml  -e ~/templates/post-deployment.yaml


In the Red Hat documentation https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Updating_the_Overcloud.html#sect-Updating_the_Overcloud_Packages it is mentioned to include "overcloud-resource-registry-puppet.yaml" Heat template.

Perhaps this is a doc bug?
Comment 7 Dan Macpherson 2016-01-28 20:31:21 EST
Hi Jon,

You probably saw the email thread. So the problem is the lack of the RHSM/Satellite information, which you need to also include as an environment file along with "overcloud-resource-registry-puppet.yaml". If this information isn't included, the director concludes that the Overcloud environment does not contain registration and as a result unregisters the nodes.

I'll include a line in the doc to also include the registration environment file during the update.

Note You need to log in before you can comment on or make changes to this bug.