Bug 1290313 - eth hw csum failure oopses
eth hw csum failure oopses
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 02:49 EST by Michal Hlavinka
Modified: 2016-10-12 08:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-12 08:32:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (91.46 KB, text/plain)
2015-12-10 02:50 EST, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2015-12-10 02:49:03 EST
Description of problem:
I have 4x eth nic server, 1x wlan. One eth is used external interface ethext0, other (ethint0, ethint1, ethint2, wlan0) are bridged as bridge0.

After update to Fedora 23, I'm getting kernel oopses.

Version-Release number of selected component (if applicable):
kernel-4.2.6-301.fc23.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
[   21.621981] IPv6: ADDRCONF(NETDEV_UP): bridge0: link is not ready
[   21.636241] IPv6: ADDRCONF(NETDEV_UP): ethext0: link is not ready
[   21.640737] sky2 0000:01:00.0 ethext0: enabling interface
[   21.640978] IPv6: ADDRCONF(NETDEV_UP): ethext0: link is not ready
[   21.654638] IPv6: ADDRCONF(NETDEV_UP): ethint1: link is not ready
[   21.662063] r8169 0000:03:00.0 ethint1: link down
[   21.662281] IPv6: ADDRCONF(NETDEV_UP): ethint1: link is not ready
[   21.677429] IPv6: ADDRCONF(NETDEV_UP): ethint0: link is not ready
[   21.680167] sky2 0000:02:00.0 ethint0: enabling interface
[   21.680379] IPv6: ADDRCONF(NETDEV_UP): ethint0: link is not ready
[   21.691558] IPv6: ADDRCONF(NETDEV_UP): ethint2: link is not ready
[   21.697426] r8169 0000:04:00.0 ethint2: link down
[   21.697636] IPv6: ADDRCONF(NETDEV_UP): ethint2: link is not ready
[   21.776422] IPv6: ADDRCONF(NETDEV_UP): bridge0: link is not ready
[   23.356827] sky2 0000:01:00.0 ethext0: Link is up at 100 Mbps, full duplex, flow control rx
[   23.356827] IPv6: ADDRCONF(NETDEV_CHANGE): ethext0: link becomes ready
[   24.700884] sky2 0000:02:00.0 ethint0: Link is up at 1000 Mbps, full duplex, flow control both
[   24.700884] IPv6: ADDRCONF(NETDEV_CHANGE): ethint0: link becomes ready
[   24.727992] device ethint0 entered promiscuous mode
[   24.728298] bridge0: port 1(ethint0) entered forwarding state
[   24.728362] bridge0: port 1(ethint0) entered forwarding state
[   24.728726] IPv6: ADDRCONF(NETDEV_CHANGE): bridge0: link becomes ready
[   39.775043] bridge0: port 1(ethint0) entered forwarding state
[   51.022162] ethint0: hw csum failure
[   51.022277] CPU: 2 PID: 0 Comm: swapper/2 Not tainted 4.2.6-301.fc23.x86_64 #1
[   51.022286] Hardware name: Supermicro X7SLA/X7SLA, BIOS 1.0     05/05/2009
[   51.022293]  0000000000000000 5ad746c0ae9fb978 ffff88007f503998 ffffffff817729ea
[   51.022306]  0000000000000000 ffff880036258000 ffff88007f5039b8 ffffffff8165ddd0
[   51.022315]  ffffffff8164bcb0 ffff880078b62800 ffff88007f5039e8 ffffffff8165494c
[   51.022324] Call Trace:
[   51.022331]  <IRQ>  [<ffffffff817729ea>] dump_stack+0x45/0x57
[   51.022356]  [<ffffffff8165ddd0>] netdev_rx_csum_fault+0x40/0x50
[   51.022368]  [<ffffffff8164bcb0>] ? reqsk_fastopen_remove+0x160/0x160
[   51.022379]  [<ffffffff8165494c>] __skb_checksum_complete+0xbc/0xd0
[   51.022390]  [<ffffffff81755588>] ipv6_mc_validate_checksum+0x98/0x150
[   51.022400]  [<ffffffff81650b3e>] skb_checksum_trimmed+0x9e/0x190
[   51.022410]  [<ffffffff81755769>] ipv6_mc_check_mld+0x129/0x340
[   51.022436]  [<ffffffffa0459447>] br_multicast_rcv+0x87/0xcd0 [bridge]
[   51.022452]  [<ffffffffa044d232>] ? fdb_notify+0xb2/0xe0 [bridge]
[   51.022468]  [<ffffffffa044e053>] ? br_fdb_update+0x113/0x200 [bridge]
[   51.022484]  [<ffffffffa04504d2>] br_handle_frame_finish+0x2a2/0x5f0 [bridge]
[   51.022501]  [<ffffffffa045098a>] br_handle_frame+0x16a/0x290 [bridge]
[   51.022513]  [<ffffffff81660e54>] __netif_receive_skb_core+0x384/0xa00
[   51.022523]  [<ffffffff81753ef0>] ? ipv6_gro_receive+0x230/0x320
[   51.022533]  [<ffffffff816614e8>] __netif_receive_skb+0x18/0x60
[   51.022544]  [<ffffffff81661570>] netif_receive_skb_internal+0x40/0xb0
[   51.022554]  [<ffffffff81662175>] napi_gro_receive+0xb5/0xf0
[   51.022570]  [<ffffffffa0006373>] sky2_poll+0x613/0xda0 [sky2]
[   51.022581]  [<ffffffff81661a5c>] net_rx_action+0x20c/0x310
[   51.022593]  [<ffffffff810a286b>] __do_softirq+0xfb/0x290
[   51.022603]  [<ffffffff810a2c19>] irq_exit+0x119/0x120
[   51.022615]  [<ffffffff8177c028>] do_IRQ+0x58/0xe0
[   51.022627]  [<ffffffff81779f2b>] common_interrupt+0x6b/0x6b
[   51.022634]  <EOI>  [<ffffffff81108abf>] ? hrtimer_start_range_ns+0x1bf/0x3b0
[   51.022653]  [<ffffffff81616780>] ? cpuidle_enter_state+0x130/0x270
[   51.022664]  [<ffffffff8161675b>] ? cpuidle_enter_state+0x10b/0x270
[   51.022674]  [<ffffffff816168f7>] cpuidle_enter+0x17/0x20
[   51.022685]  [<ffffffff810dfcf2>] call_cpuidle+0x32/0x60
[   51.022695]  [<ffffffff816168d3>] ? cpuidle_select+0x13/0x20
[   51.022705]  [<ffffffff810dff88>] cpu_startup_entry+0x268/0x320
[   51.022718]  [<ffffffff8104cd36>] start_secondary+0x186/0x1c0
[   51.776118] ethint0: hw csum failure


Expected results:


Additional info:
this was working in Fedora 21

ethint1 and ethint2 are not connected atm, so "link down" status is correct

lspci -nn:
00:00.0 Host bridge [0600]: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub [8086:2770] (rev 02)
00:01.0 PCI bridge [0604]: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port [8086:2771] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 1 [8086:27d0] (rev 01)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 [8086:27e0] (rev 01)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 [8086:27e2] (rev 01)
00:1d.0 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 [8086:27c8] (rev 01)
00:1d.1 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 [8086:27c9] (rev 01)
00:1d.2 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 [8086:27ca] (rev 01)
00:1d.3 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 [8086:27cb] (rev 01)
00:1d.7 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller [8086:27cc] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086:27b8] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)
00:1f.2 SATA controller [0106]: Intel Corporation NM10/ICH7 Family SATA Controller [AHCI mode] [8086:27c1] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation NM10/ICH7 Family SMBus Controller [8086:27da] (rev 01)
01:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362] (rev 19)
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362] (rev 19)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 02)
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 02)
05:00.0 Network controller [0280]: Ralink corp. RT2561/RT61 802.11g PCI [1814:0301]
Comment 1 Michal Hlavinka 2015-12-10 02:50 EST
Created attachment 1104246 [details]
dmesg log
Comment 2 Laura Abbott 2016-09-23 15:57:09 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 Michal Hlavinka 2016-10-12 08:32:43 EDT
I have moved to Fedora 24 and can't see the problem now

Note You need to log in before you can comment on or make changes to this bug.