Bug 1290315 - New vNIC - It takes time for the profile to be loaded
New vNIC - It takes time for the profile to be loaded
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.1.2
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Yevgeny Zaspitsky
Michael Burman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 03:35 EST by Michael Burman
Modified: 2016-02-18 06:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:11:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50466 master MERGED webadmin: fix vnic type init in (New|Edit)VnicModel 2015-12-20 08:50 EST
oVirt gerrit 50468 ovirt-engine-3.6 MERGED webadmin: fix vnic type init in (New|Edit)VnicModel 2015-12-22 03:36 EST
oVirt gerrit 50896 master MERGED webadmin: Fix supported vnic types init 2015-12-22 08:46 EST
oVirt gerrit 50903 ovirt-engine-3.6 MERGED webadmin: Fix supported vnic types init 2015-12-22 13:34 EST
oVirt gerrit 50924 ovirt-engine-3.6.2 MERGED webadmin: Fix supported vnic types init 2015-12-23 04:12 EST

  None (edit)
Description Michael Burman 2015-12-10 03:35:11 EST
Description of problem:
New vNIC - It takes time for the profile to be loaded.  
Because of that, we first see the first type from the list rt8139 and after few seconds the right type -VirtIO(the default type for new vNIC). It is not pretty.

Version-Release number of selected component (if applicable):
3.6.1.2-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Add new vNIC to VM

Actual results:
It takes time for the profile to be loaded.
rt8139 type is displayed first and then changing to the right type - VirtIO

Expected results:
Should display VirtIO(like on 3.5.z)
Comment 1 Michael Burman 2015-12-10 03:50:41 EST
Same for edit vNIC.
Comment 2 Red Hat Bugzilla Rules Engine 2015-12-14 15:08:13 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Red Hat Bugzilla Rules Engine 2015-12-22 03:36:27 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-22 04:01:36 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Red Hat Bugzilla Rules Engine 2015-12-22 04:37:57 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-22 09:03:54 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Sandro Bonazzola 2015-12-23 10:08:25 EST
This bug has target milestone 3.6.2 and is on modified without a target release.
This may be perfectly correct, but please check if the patch fixing this bug is included in ovirt-engine-3.6.2. If it's included, please set target-release to 3.6.2 and move to ON_QA. Thanks.
Comment 8 Michael Burman 2016-01-17 04:35:48 EST
Verified on - 3.6.2.5-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.