This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290316 - Package changes via Content Host ommands are not reflected in Audits
Package changes via Content Host ommands are not reflected in Audits
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Audit Log (Show other bugs)
6.1.4
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 03:40 EST by Roland Wolters
Modified: 2017-01-11 16:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-11 16:47:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2015-12-10 03:40:02 EST
Description of problem:
System changes like package installs or removals which are triggered via the web interface from the content host view are not shown in the audit log.
This is an issue since the audit should provide an insight into all changes made to a system.


Version-Release number of selected component (if applicable):
6.1.4

How reproducible:
Install or remove a package, check the audit log afterwards.

Steps to Reproduce:
1. in the Satellite web ui got to Hosts -> Content Hosts, pick a host
2. change to tab packages, install or remove any package
3. check back on the host that the task has been performed
4. in the Satellite web ui, go to Monitor -> Audits, check the audit logs for the given host

Actual results:
The log does not reflect the package changes made to the system

Expected results:
The changes should show up in the audit logs
Comment 1 Bryan Kearney 2016-07-26 15:08:56 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Bryan Kearney 2017-01-11 16:47:09 EST
This is an older bug which I do not envision being fixed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.