Bug 129033 - no automatic USB drive entry in fstab
Summary: no automatic USB drive entry in fstab
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kudzu   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 129244
TreeView+ depends on / blocked
 
Reported: 2004-08-03 11:20 UTC by Leigh Upton
Modified: 2014-03-17 02:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 14:21:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:509 normal SHIPPED_LIVE Updated kudzu packages 2004-12-21 05:00:00 UTC

Description Leigh Upton 2004-08-03 11:20:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When inserting a USB drive that is not explicitely mention in the 
updfstab.conf* files, no fstab entry is generated to allow a normal 
user to mount it. This means that unless every single USB dongle on 
the market that in fact supported by the usb-storage driver is 
mentioned by model name, this will only work for a very selected few 
USB drives. 
This is a bug and completely unsupportable in an enterprise 
environment. Is there a solution for this other than generating a 
huge updfstab.conf?

Gr,
Xander

Version-Release number of selected component (if applicable):
1.1.22.2-1

How reproducible:
Always

Steps to Reproduce:
1. Insert USB dongle
2. Watch as nothing happens
3.
    

Actual Results:  Nothing

Expected Results:  /etc/fstab should have an entry for the device 
with the "user" option so non-root users can mount it.

Additional info:

Comment 1 Bill Nottingham 2004-08-03 13:29:14 UTC
There is some work being done for future releases for this with
gnome-volume-manager.

Asidee from that, updfstab.conf changes are what's needed for RHEL 3.

Comment 2 Leigh Upton 2004-08-18 06:33:06 UTC
Here's the output of kudzu -p -b scsi as requested via email by Bill 
Nottingham.

-
class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "Qsi CDRW/DVD SBW-242"
host: 1
id: 0
channel: 0
lun: 0
generic: sg0
-
class: HD
bus: SCSI
detached: 0
device: sda
driver: ignore
desc: "Apacer HandyDrive"
host: 2
id: 0
channel: 0
lun: 0
generic: sg

Gr,
Xander

Comment 3 Bill Nottingham 2004-08-18 15:53:08 UTC
What sort of USB drive is this? (flash, SD, etc.)

Comment 4 Leigh Upton 2004-08-19 14:16:24 UTC
It's a std USB pen drive, 128MB, nothing fancy. Looks like this one: 
http://www.apacer.com/apacer_english/product_html/handy_steno20.asp, 
only USB 1.1, not 2.0.

Gr,
Xander


Comment 6 John Flanagan 2004-12-21 14:21:57 UTC
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-509.html



Note You need to log in before you can comment on or make changes to this bug.