Bug 1290372 - After upgrading vdsm rpms from 3.3 or 3.4 to 3.6, vdsm fails to restart because it's not configured [NEEDINFO]
After upgrading vdsm rpms from 3.3 or 3.4 to 3.6, vdsm fails to restart becau...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.11
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 4.17.14
Assigned To: Oved Ourfali
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 05:52 EST by Yeela Kaplan
Modified: 2016-02-18 06:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:12:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nsoffer: needinfo? (ykaplan)
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48106 None None None Never
oVirt gerrit 49510 ovirt-3.6 MERGED init: configure multipath on upgrade from ovirt-3.3 and 3.4 Never

  None (edit)
Description Yeela Kaplan 2015-12-10 05:52:43 EST
Description of problem:
After upgrading vdsm rpms from 3.3 or 3.4 to 3.6, vdsm fails to restart:

To fix is necessary to manually run:
vdsm-tool configure --force

Version-Release number of selected component (if applicable):
upgrading from vdsm-4.13 or 4.14 to vdsm-4.17

How reproducible:
100%

Steps to Reproduce:
1. deploy the host with 3.3 or 3.4 repo
2. add 3.6 repo
3. yum update
4. VDSM will not restart

Actual results:
VDSM will not restart after yum update because multipath and passwd are not configured

Expected results:
Multipath and passwd should be configured during upgrade.
Comment 1 Nir Soffer 2015-12-10 06:10:49 EST
How multipath is not configured after upgrading an existing setup?
Comment 2 Red Hat Bugzilla Rules Engine 2015-12-10 21:25:22 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 3 Red Hat Bugzilla Rules Engine 2015-12-11 02:17:17 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-11 02:44:18 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Red Hat Bugzilla Rules Engine 2015-12-11 02:49:46 EST
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 6 Sandro Bonazzola 2015-12-23 08:44:33 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 7 Lukas Svaty 2016-01-21 10:00:48 EST
working on vdsm-4.17.18-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.