Bug 1290387 - openstack-sahara-api fails to start in Mitaka-1, cannot find api-paste.ini
openstack-sahara-api fails to start in Mitaka-1, cannot find api-paste.ini
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-sahara (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: Milestone2
: trunk
Assigned To: RHOS Maint
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 06:39 EST by Javier Peña
Modified: 2016-03-14 05:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 05:40:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 254744 None None None Never

  None (edit)
Description Javier Peña 2015-12-10 06:39:17 EST
Description of problem:

During the Mitaka-1 test day, openstack-sahara-api fails to start after a Packstack installation. sahara-api.log shows the following error:

2015-12-10 11:56:34.528 6986 INFO sahara.utils.rpc [-] Notifications disabled
2015-12-10 11:56:34.922 6986 INFO sahara.plugins.base [-] Plugin hdp loaded sahara.plugins.hdp.ambariplugin:AmbariPlugin
2015-12-10 11:56:34.923 6986 INFO sahara.plugins.base [-] Plugin vanilla loaded sahara.plugins.vanilla.plugin:VanillaProvider
2015-12-10 11:56:34.923 6986 INFO sahara.plugins.base [-] Plugin cdh loaded sahara.plugins.cdh.plugin:CDHPluginProvider
2015-12-10 11:56:34.924 6986 INFO sahara.plugins.base [-] Plugin spark loaded sahara.plugins.spark.plugin:SparkProvider
2015-12-10 11:56:34.924 6986 INFO sahara.main [-] Sahara API started
2015-12-10 11:56:34.924 6986 CRITICAL sahara [-] ConfigNotFound: Could not find config at api-paste.ini
2015-12-10 11:56:34.924 6986 ERROR sahara Traceback (most recent call last):
2015-12-10 11:56:34.924 6986 ERROR sahara   File "/usr/bin/sahara-api", line 10, in <module>
2015-12-10 11:56:34.924 6986 ERROR sahara     sys.exit(main())
2015-12-10 11:56:34.924 6986 ERROR sahara   File "/usr/lib/python2.7/site-packages/sahara/cli/sahara_api.py", line 51, in main
2015-12-10 11:56:34.924 6986 ERROR sahara     app = server.make_app()
2015-12-10 11:56:34.924 6986 ERROR sahara   File "/usr/lib/python2.7/site-packages/sahara/main.py", line 116, in make_app
2015-12-10 11:56:34.924 6986 ERROR sahara     app_loader = oslo_wsgi.Loader(CONF)
2015-12-10 11:56:34.924 6986 ERROR sahara   File "/usr/lib/python2.7/site-packages/oslo_service/wsgi.py", line 340, in __init__
2015-12-10 11:56:34.924 6986 ERROR sahara     raise ConfigNotFound(path=config_path)
2015-12-10 11:56:34.924 6986 ERROR sahara ConfigNotFound: Could not find config at api-paste.ini
2015-12-10 11:56:34.924 6986 ERROR sahara 

It looks like the path for api-paste.ini is not properly set in the distro-provided /etc/sahara/sahara.conf

Version-Release number of selected component (if applicable):
openstack-sahara-common-4.0.0.0b2-dev12.el7.centos.noarch

Workaround:

Set api_paste_config = /usr/share/sahara/api-paste.ini in /etc/sahara/sahara.conf
Comment 1 Javier Peña 2015-12-10 07:36:16 EST
Proposed https://review.gerrithub.io/254744 with a packaging fix.
Comment 2 Luigi Toscano 2016-03-14 05:40:28 EDT
This is indeed fixed in recent snapshots of Mitaka.

Verified on an up-to-date CentOS 7 using:
openstack-packstack-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-packstack-puppet-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-puppet-modules-8.0.0a0-0.20160304203011.7dc7e93.el7.centos.noarch
openstack-sahara-api-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
openstack-sahara-common-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
openstack-sahara-engine-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
python-sahara-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch

Note You need to log in before you can comment on or make changes to this bug.