Bug 1290412 - `show vm` does not accept --name
`show vm` does not accept --name
Status: CLOSED NOTABUG
Product: ovirt-engine-cli
Classification: oVirt
Component: General (Show other bugs)
3.6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Juan Hernández
Pavel Stehlik
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 08:08 EST by Petr Horáček
Modified: 2016-05-10 06:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 06:29:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.1?
rule-engine: blocker?
juan.hernandez: planning_ack?
juan.hernandez: devel_ack+
juan.hernandez: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Petr Horáček 2015-12-10 08:08:23 EST
Description of problem:
Command `ovirt-shell -E 'show vm --name test_25'` fails with:
================= ERROR ================
    vm identifier or name required.
========================================
When I call it without --name, just `ovirt-shell -E 'show vm test_25'`, it's ok. --name used to work in 3.6.

Version-Release number of selected component (if applicable):
ovirt-engine-cli.noarch            4.0.0.0-0.3.20151119.git489d187.fc22 @ovirt-master-snapshot
ovirt-engine-sdk-python.noarch     4.0.0.0-0.2.20151123.git8ba204b.fc22 @ovirt-master-snapshot

How reproducible:
Always

Steps to Reproduce:
1. show vm --name test_25

Actual results:
Error

Expected results:
List of vm parameters
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-10 21:32:38 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Oved Ourfali 2016-03-13 03:35:37 EDT
We don't plan any work on the CLI in 4.0.
Comment 3 Juan Hernández 2016-05-10 06:29:08 EDT
The --name option was never intended for this usage, the right way to get the details of an object, by name or id is the following:

  # show vm the_name_or_id

That works correctly.

Note You need to log in before you can comment on or make changes to this bug.