Bug 1290517 - mysql_config --libmysqld-libs includes '-laio' (and has to dependency on libaio-devel)
mysql_config --libmysqld-libs includes '-laio' (and has to dependency on liba...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schorm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 12:29 EST by Rex Dieter
Modified: 2016-12-07 03:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-07 03:32:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2015-12-10 12:29:49 EST
rpm -q mariadb-devel
mariadb-devel-10.1.8-3.fc24


Summary says it all, packages that build using output from 

$ mysql_config --libmysqld-libs
-L/usr/lib64/mysql  -lmysqld -lpthread -lz -lm -ldl -lssl -lcrypto -lpcre -lcrypt -laio

Fails with
/usr/bin/ld: cannot find -laio

(because of libaio-devel missing and no dependency).
Comment 1 Honza Horak 2016-02-12 06:47:27 EST
There is the dependency in mariadb-embedded:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=7386714

But was missing in mariadb-embedded-devel, which should be fixed in upcoming 1:10.1.11-7.
Comment 2 Jan Kurik 2016-02-24 09:07:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Admin XMLRPC Client 2016-11-15 05:32:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Michal Schorm 2016-12-07 03:32:49 EST
BuildRequires: libaio-devel
dependency added

Note You need to log in before you can comment on or make changes to this bug.