Bug 1290587 - kills session if there is screensaver trouble
kills session if there is screensaver trouble
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-session-manager (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 16:24 EST by Sami Farin
Modified: 2016-04-14 06:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 06:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2015-12-10 16:24:22 EST
Description of problem:

I was watching movie with mplayer, and I paused it while doing some other stuff.
I have in mplayer
  heartbeat-cmd="mate-screensaver-command -d"

Then, suddenly, mate session gets killed.

Dec 10 22:46:02 x audit: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dnf-makecache comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Dec 10 23:07:31 x mate-session[5778]: WARNING: Detected that screensaver has left the bus
Dec 10 23:07:31 x org.gtk.vfs.Daemon: A connection to the bus can't be made
Dec 10 23:07:32 x org.mate.panel.applet.WnckletFactory: wnck-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Dec 10 23:07:32 x org.mate.panel.applet.NotificationAreaAppletFactory: notification-area-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Dec 10 23:07:32 x org.gtk.vfs.Daemon: A connection to the bus can't be made
Dec 10 23:07:32 x acpid: client 5415[0:0] has disconnected
Dec 10 23:07:32 x audit: <audit-1106> pid=8019 uid=500 auid=500 ses=2 msg='op=PAM:session_close grantors=pam_keyinit,pam_keyinit,pam_limits,pam_systemd,pam_unix,pam_xauth,pam_namespace acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=pts/1 res=success'
Dec 10 23:07:32 x audit: <audit-1104> pid=7942 uid=500 auid=500 ses=2 msg='op=PAM:setcred grantors=pam_unix acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=pts/9 res=success'
Dec 10 23:07:33 x acpid: client connected from 25095[0:0]
Dec 10 23:07:33 x acpid: 1 client rule loaded
Dec 10 23:07:34 x systemd-logind: Removed session c1.
Dec 10 23:07:34 x systemd: Stopping User Manager for UID 428...
Dec 10 23:07:34 x systemd: Reached target Shutdown.
Dec 10 23:07:34 x systemd: Starting Shutdown.
Dec 10 23:07:34 x systemd: Stopped target Default.
Dec 10 23:07:34 x systemd: Stopping Default.
Dec 10 23:07:34 x systemd: Starting Exit the Session...
Dec 10 23:07:34 x systemd: Stopped target Basic System.
Dec 10 23:07:34 x systemd: Stopping Basic System.
Dec 10 23:07:34 x systemd: Stopped target Sockets.
Dec 10 23:07:34 x systemd: Stopping Sockets.
Dec 10 23:07:34 x systemd: Stopped target Timers.
Dec 10 23:07:34 x systemd: Stopping Timers.
Dec 10 23:07:34 x systemd: Stopped target Paths.
Dec 10 23:07:34 x systemd: Stopping Paths.
Dec 10 23:07:34 x systemd: Received SIGRTMIN+24 from PID 25104 (kill).

Version-Release number of selected component (if applicable):
1.12.0


Actual results:
log out

Expected results:
nothing

Additional info:
Comment 1 Wolfgang Ulbrich 2015-12-12 13:30:23 EST
Hmm, i do not see that "mate-screensaver-command -d" execute in a terminal kill mate-session.
Does this works for you not using the command in mplayer config?
Comment 2 Sami Farin 2015-12-12 14:07:10 EST
Do you have other ideas about what happened?
Mate does not crash if I have that command in config IF mplayer is not paused for a long time.  

Well, I try again.
Comment 3 Wolfgang Ulbrich 2015-12-30 13:33:14 EST
You didn't understand what i wanted to know.
Does "mate-screensaver-command -d" execute in a terminal kill mate-session in your box?
Comment 4 Sami Farin 2015-12-30 14:44:16 EST
Nope.  

I got another crash, I was watching movie in mplayer and session crashed when I pressed enter for next movie.  

org.mate.panel.applet.WnckletFactory[10145]: wnck-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
polkitd[4474]: Unregistered Authentication Agent for unix-session:4 (system bus name :1.93, object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_US.utf8) (disconnected from bus)

oh yay, I had in .xsession-errors.old the following. (the same time as above, file timestamp 22:30:26.204787638 )
web.whatsapp.com has enabled notifications in Chrome.

In xfce4 I don't get warnings about whatsapp.

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2c00001 (WhatsApp W)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2c00001 (WhatsApp W)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(mate-screensaver:10439): GLib-CRITICAL **: Source ID 3447 was not found when attempting to remove it

(mate-power-manager:10449): GLib-CRITICAL **: Source ID 804 was not found when attempting to remove it

(mate-screensaver:10439): GLib-CRITICAL **: Source ID 3490 was not found when attempting to remove it

(mate-power-manager:10449): GLib-CRITICAL **: Source ID 813 was not found when attempting to remove it
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4600001 (https://we)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4600001 (https://we)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(mate-power-manager:10449): GLib-CRITICAL **: Source ID 860 was not found when attempting to remove it

(mate-screensaver:10439): GLib-CRITICAL **: Source ID 3543 was not found when attempting to remove it

(mate-power-manager:10449): GLib-CRITICAL **: Source ID 863 was not found when attempting to remove it

(mate-screensaver:10439): GLib-CRITICAL **: Source ID 3667 was not found when attempting to remove it
(mate-power-manager:10449): GLib-CRITICAL **: Source ID 879 was not found when attempting to remove it

(mate-screensaver:10439): GLib-CRITICAL **: Source ID 3725 was not found when attempting to remove it

(mate-power-manager:10449): GLib-CRITICAL **: Source ID 887 was not found when attempting to remove it

(mate-panel:10373): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

mate-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Comment 5 Wolfgang Ulbrich 2015-12-30 14:51:50 EST
It is not helpful if you don't answer my question!
How should i help you?
Please do not spam this report with another issue!
Please open a new one.
Comment 6 Sami Farin 2015-12-30 14:57:28 EST
I answered, answer was "Nope.", now I am thinking whatsapp is causing the crash.
Comment 7 Wolfgang Ulbrich 2015-12-30 14:58:40 EST
(In reply to Sami Farin from comment #4)
> Nope.  
> 
Ok, i didn't saw this answer.

So it looks like that mplayer caused the issue when using this command.

> I got another crash, I was watching movie in mplayer and session crashed when I pressed enter for next movie.

Honestly, this is a problem with mplayer.
I suggest to open a report against mplayer.
Comment 8 Sami Farin 2015-12-30 15:04:36 EST
Honestly, what about that whatsapp thing?
Comment 9 Wolfgang Ulbrich 2015-12-30 15:10:07 EST
I don't know 'whatsapp' and this is not a fedora package.
Btw. i use gnome-mplayer from rpmfusion which supports mate-screensaver out of box ;)

Note You need to log in before you can comment on or make changes to this bug.