Bug 1290646 - Allow trivial monitoring of kill switch
Allow trivial monitoring of kill switch
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Internal Tools (Show other bugs)
4.4
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 22:01 EST by Will Thames
Modified: 2016-08-15 21:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 23:04:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Thames 2015-12-10 22:01:44 EST
Provide a mechanism to monitor whether the kill switch is enabled. 

This could be as simple as 

http://bugzilla.example.com/kill_switch_status

but as long as it's easy to determine the status, I'm not particularly concerned about the implementation details. 

I don't believe the state of the switch is particularly sensitive (even if the reason for the state might be) - so I would hope that the status would be available without logging in.
Comment 1 Jason McDonald 2015-12-10 22:13:10 EST
(In reply to Will Thames from comment #0)
> I don't believe the state of the switch is particularly sensitive (even if
> the reason for the state might be) - so I would hope that the status would
> be available without logging in.

FWIW, I agree that the kill switch state is not secret.  In the original design, we only showed the state of the kill switch to users in the rule-engine group because they were the only users who could do something about it.  Unfortunately, we didn't consider the possibility of a monitoring system wanting to see the state.
Comment 2 Jeff Fearn 2016-06-15 22:11:56 EDT
I think this should be done as a DB query

"select count(*) > 0 from rh_rule_state where when_enabled IS NULL"
Comment 3 Jeff Fearn 2016-07-05 23:04:23 EDT
As I said in #2 this should be done by adding that sql to the monitoring system.

Note You need to log in before you can comment on or make changes to this bug.