Bug 1290657 - Cross binutils for powerpc lacks little-endian targets
Cross binutils for powerpc lacks little-endian targets
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cross-binutils (Show other bugs)
23
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Howells
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 00:03 EST by David Gibson
Modified: 2015-12-11 00:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 00:14:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2015-12-11 00:03:06 EST
Description of problem:

Although powerpc is traditionally a big-endian architecture, CPUs have actually supported both endian modes for some time.  At least on IBM servers, little-endian is now the encouraged mode of operation.

However, the cross binutils for powerpc targets only includes the emulations for big-endian powerpc.

Version-Release number of selected component (if applicable):

binutils-powerpc64-linux-gnu-2.25-5.fc23.x86_64

How reproducible:

100%

Steps to Reproduce:
1. $ powerpc64-linux-gnu-ld -V

Actual results:

$ powerpc64-linux-gnu-ld -V
GNU ld version 2.25-5.fc23
  Supported emulations:
   elf64ppc
   elf32ppc
   elf32ppclinux
   elf32ppcsim


Expected results:

Something closer to the output on a native ld on a ppc64le system:

$ uname -a
Linux ibm-p8-virt-01.lab.bos.redhat.com 3.10.0-334.el7_BZ1287474test2.ppc64le #1 SMP Tue Dec 8 13:11:56 EST 2015 ppc64le ppc64le ppc64le GNU/Linux
$ ld -V
GNU ld version 2.23.52.0.1-55.el7 20130226
  Supported emulations:
   elf64lppc
   elf32lppc
   elf32lppclinux
   elf32lppcsim
   elf32_spu
   elf32ppclinux
   elf32ppc
   elf32ppcsim
   elf64ppc


Additional info:
Comment 1 David Gibson 2015-12-11 00:14:18 EST
Sorry, never mind.

Looks like a fix is already there in brew, just hasn't made it to the repositories yet.

Given that powerpc native binutils is configured to include both BE and LE targets, it's not clear that having separate cross-binutils packages for BE and LE targets is the best choic, though.

Note You need to log in before you can comment on or make changes to this bug.