Bug 1290673 - Miscellaneous errors in Performance Tuning Guide
Miscellaneous errors in Performance Tuning Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Performance_Tuning_Guide (Show other bugs)
7.2
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Milan Navratil
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 00:52 EST by Kwan Lowe
Modified: 2016-11-14 06:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-14 06:06:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kwan Lowe 2015-12-11 00:52:10 EST
Document URL:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Performance_Tuning_Guide/index.html 

Section Number and Name: 
Multiple. See Additional Information.

Describe the issue: 
Miscellaneous typos, wording

Suggestions for improvement: 
Please see below.

Additional information: 
Bugzilla - Performance Guide Errata

4.3.2.1

Typo - errant space in "of"

OLD:
Specifies the percentage o f physical RAM considered when overcommit_memory is set to 2. The default value is 50.

NEW:
Specifies the percentage of physical RAM considered when overcommit_memory is set to 2. The default value is 50.


Possessive form of process 

OLD:
Processes spawned by an adjusted process inherit that process's oom_score.
NEW:
Processes spawned by an adjusted process inherit the oom_score of the process.
NEW:
Processes spawned by an adjusted process inherit that process' oom_score.


Incomplete sentence, verb agreement, unnecessary comma

OLD:
swappiness
A value from 0 to 100 which controls the degree to which the system favour anonymous memory or the page cache. A high value improves file-system performance, while aggressively swapping less active processes out of RAM. A low value avoids swapping processes out of memory, which usually decrease latency, at the cost of I/O performance. The default value is 60.

NEW:
The swappiness value, ranging from 0 to 100, controls the degree to which the system favours anonymous memory or the page cache. A high value improves file-system performance while aggressively swapping less active processes out of RAM. A low value avoids swapping processes out of memory, which usually decreases latency at the cost of I/O performance. The default value is 60.

--


4.2.3
Missing version number in shmall, shmax, 

OLD:
Defines the total amount of shared memory in pages that can be used on the system at one time. As of Red Hat Enterprise Linux, the default value is 1<<24, or 33554432 pages.

NEW:
Defines the total amount of shared memory in pages that can be used on the system at one time. As of Red Hat Enterprise Linux 7, the default value is 1<<24, or 33554432 pages.


5.1.3.4
Maximum GFS2 capacity doesn't match other documentation:
https://access.redhat.com/solutions/1532

--


5.2.1.
The si/so is not quite clear and seems to be opposite to the manpage. 

Specifically, the vmstat manpage shows:
si: Amount of memory swapped in from disk (/s).
so: Amount of memory swapped to disk (/s).

The documentation has:
Swap in, or writes to swap space, in KB.
Swap out, or reads from swap space, in KB.

--

5.2.2.3
Suggest removing redundant "you"

OLD:
This can help you to identify when you are hitting the operations-per-second limit of a device.

NEW:
This can help to identify when you are hitting the operations-per-second limit of a device.



5.3.7.3
s/It's/Its/, run-on

OLD:
Tuning should always be done to optimize the system based on it's current workload. This section deals only with optimizing a BTRFS, for creation and mounting options see the Red Hat Enterprise Linux 7 Storage Administration Guide, 

NEW:
Tuning should always be done to optimize the system based on its current workload. This section deals only with optimizing a BTRFS file system. For creation and mounting options see the Red Hat Enterprise Linux 7 Storage Administration Guide, 


--
5.3.7.3.1

Remove contraction, redundant parenthetical.

OLD:
compress=zlib - Better compression ratio. It's the default and safe for older kernels.(default).

NEW:
compress=zlib - Better compression ratio. It is the default and safe for older kernels.


OLD:
compress-force=method - Enable compression even for files that don't compress well, like videos and images of disks. 

NEW:
compress-force=method - Enable compression even for files that do not compress well, such as videos and images of disks.

Formatting example should be clearer

OLD:
$ btrfs filesystem defragment -calg

NEW:
$ btrfs filesystem defragment -c[ALG]

where ALG is either zlib or lzo.
Comment 1 Milan Navratil 2016-03-11 11:24:59 EST
Hi Kwan,

Thank you for taking the time to file this bug. I'll make the fixes and let you know as soon as I republish the Red Hat Enterprise Linux 7 Performance Tuning Guide.

Milan
Comment 5 Milan Navratil 2016-08-29 11:39:12 EDT
Hello Kwan,

I've incorporated all the changes you suggested. Thank you very much for pointing them out.

Unfortunately, this content has not been, by accident, included in the asynchronous updates, as it hasn't been merged, and this BZ has slipped through the cracks, I'm afraid.

I'll leave a comment and include a link when the changes appear on the Red Hat Customer Portal.

Thank you very much again and sorry for taking so long.
Comment 6 Milan Navratil 2016-11-14 06:06:22 EST
An updated version of the Red hat Enterprise Linux 7 Performance Tuning Guide is now available on the Customer Portal:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Performance_Tuning_Guide/index.html

Note You need to log in before you can comment on or make changes to this bug.