Bug 1290685 - Can't run tests due to failure to correctly delete symlinks
Can't run tests due to failure to correctly delete symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 02:29 EST by Alexander Kurtakov
Modified: 2016-02-23 14:22 EST (History)
7 users (show)

See Also:
Fixed In Version: eclipse-4.5.1-12.fc24 eclipse-4.5.1-12.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 14:22:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2015-12-11 02:29:58 EST
Running eclipse-runEclipsePackageTests fails with:
/usr/share/java/eclipse-testing/test.xml:1261: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:1278: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:1386: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:915: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:764: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:783: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:128: The following error occurred while executing this line:
/usr/share/java/eclipse-testing/test.xml:190: Unable to delete file /tmp/eclipse-tests-directory/test-eclipse/eclipse/dropins/pydev-core/eclipse/plugins/org.python.pydev.jython_4.4.0.201511291100/Lib/SimpleHTTPServer.py

This is some collision with pydev but the tests runner should be able to properly clear stuff created by it.
Comment 1 Mat Booth 2016-02-16 20:24:43 EST
This was caused by some brain-damaged implementation of deleting directories in ant (failure to do the right thing with symlinks)
Comment 2 Fedora Update System 2016-02-17 10:07:38 EST
eclipse-4.5.1-12.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfb1b334da
Comment 3 Fedora Update System 2016-02-17 17:31:02 EST
eclipse-4.5.1-12.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfb1b334da
Comment 4 Fedora Update System 2016-02-23 14:22:11 EST
eclipse-4.5.1-12.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.