This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290752 - ISE on duplicate hostname page: JVMDUMP013I Processed dump event "systhrow", detail "java/lang/OutOfMemoryError".
ISE on duplicate hostname page: JVMDUMP013I Processed dump event "systhrow", ...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
570
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 05:36 EST by Jan Hutař
Modified: 2017-05-17 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 16:08:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-12-11 05:36:21 EST
Description of problem:
I'm getting ISE (and java/lang/OutOfMemoryError in the catalina.out) when I try to access Systems -> Systems -> Duplicate Systems -> Duplicate Hostname


Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-120.el6sat.noarch
satellite-schema-5.7.0.20-1.el6sat.noarch
# alternatives --display java | grep 'link currently points to'
 link currently points to /usr/lib/jvm/jre-1.6.0-ibm.x86_64/bin/java


How reproducible:
always on mine machine


Steps to Reproduce:
(I do not see this on the clean system, so there must be some special setup
on the Satellite in question)
1. Go to: Systems -> Systems -> Duplicate Systems -> Duplicate Hostname


Actual results:
==> /var/log/tomcat6/catalina.out <==
JVMDUMP039I Processing dump event "systhrow", detail "java/lang/OutOfMemoryError" at 2015/12/11 05:26:24 - please wait.
JVMDUMP030W Cannot write dump to file /usr/share/tomcat6/heapdump.20151211.052624.9264.0001.phd: Permission denied
JVMDUMP032I JVM requested Heap dump using '/tmp/heapdump.20151211.052624.9264.0001.phd' in response to an event
JVMDUMP010I Heap dump written to /tmp/heapdump.20151211.052624.9264.0001.phd
JVMDUMP030W Cannot write dump to file /usr/share/tomcat6/javacore.20151211.052624.9264.0002.txt: Permission denied
JVMDUMP032I JVM requested Java dump using '/tmp/javacore.20151211.052624.9264.0002.txt' in response to an event
JVMDUMP010I Java dump written to /tmp/javacore.20151211.052624.9264.0002.txt
JVMDUMP032I JVM requested Snap dump using '/usr/share/tomcat6/Snap.20151211.052624.9264.0003.trc' in response to an event
JVMDUMP030W Cannot write dump to file /usr/share/tomcat6/Snap.20151211.052624.9264.0003.trc: Permission denied
JVMDUMP010I Snap dump written to /tmp/Snap.20151211.052624.9264.0003.trc
JVMDUMP013I Processed dump event "systhrow", detail "java/lang/OutOfMemoryError".
2015-12-11 05:26:26,036 [TP-Processor8] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException: Filter execution threw an exception
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:259)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:100)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:57)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:767)
Caused by: 
java.lang.OutOfMemoryError
: 
Java heap space
	at 
java.util.Arrays
.
copyOfRange
(
Arrays.java
:
4
2
0
1
)
	at 
java.util.Arrays
.
copyOf
(
Arrays.java
:
3
9
2
0
)
	at 
java.io.CharArrayWriter
.
toCharArray
(
CharArrayWriter.java
:
2
3
9
)
	at 
com.opensymphony.module.sitemesh.filter.Buffer
.
getContents
(
Buffer.java
:
4
0
)
	at 
com.opensymphony.module.sitemesh.filter.PageResponseWrapper
.
getContents
(
PageResponseWrapper.java
:
1
9
2
)
	at 
com.opensymphony.sitemesh.webapp.ContentBufferingResponse
.
getContent
(
ContentBufferingResponse.java
:
5
2
)
	at 
com.opensymphony.sitemesh.webapp.SiteMeshFilter
.
obtainContent
(
SiteMeshFilter.java
:
1
3
7
)
	at 
com.opensymphony.sitemesh.webapp.SiteMeshFilter
.
doFilter
(
SiteMeshFilter.java
:
7
7
)
	at 
org.apache.catalina.core.ApplicationFilterChain
.
internalDoFilter
(
ApplicationFilterChain.java
:
2
3
5
)
	... 
2
6
 more
 

Expected results:
Should work


Additional info:
System was cleany rebooted and reproducet after the reboot as well.
Comment 2 Grant Gainey 2017-05-17 16:08:11 EDT
I have had no luck reproducing this, on 5.7 or 5.8, even with over 200 dups. I'm going to close as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.