Bug 1290756 - LibVirt should set TasksMax for LXC VM
LibVirt should set TasksMax for LXC VM
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 06:11 EST by Maksim
Modified: 2016-04-11 08:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 08:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maksim 2015-12-11 06:11:26 EST
Description of problem: systemd turns on TasksMax property for 4.3+ kernels, this prevents LXC containers started with libvirt to work properly, because default value (512) is too low, systemd-nspawn uses 8196, I think the same value libvirt should use also  


Version-Release number of selected component (if applicable):
1.3.0

How reproducible:

Create a LXC VM, start it and check the value of /sys/fs/cgroup/pids/machine.slice/machine-lxc\\x2d${VM_NAME}.scope/pids.max

Actual results:

pids.max shows 512, it is too low

Expected results:

should be at least 8196
Comment 1 Cole Robinson 2016-04-10 18:49:11 EDT
Are you still seeing this issue with latest packages?
What distro are you on? What systemd version is this?
Comment 2 Maksim 2016-04-11 08:21:01 EDT
with the latest systemd and libvirt it works fine. thank you. the max.pid value  is 16384 now.
Comment 3 Cole Robinson 2016-04-11 08:21:49 EDT
thanks, closing

Note You need to log in before you can comment on or make changes to this bug.