Bug 1290768 - SELinux is preventing mdadm from 'getattr' accesses on the file /dev/shm/lldpad.state.
SELinux is preventing mdadm from 'getattr' accesses on the file /dev/shm/lldp...
Status: CLOSED DUPLICATE of bug 1288822
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8f42bb845757bc84c7789526a11...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 07:11 EST by Jake Jackson
Modified: 2015-12-15 10:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 10:42:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Jackson 2015-12-11 07:11:36 EST
Description of problem:
sudo mdadm --assemble --scan
SELinux is preventing mdadm from 'getattr' accesses on the file /dev/shm/lldpad.state.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/dev/shm/lldpad.state default label should be lldpad_tmpfs_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /dev/shm/lldpad.state

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that mdadm should be allowed getattr access on the lldpad.state file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mdadm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:mdadm_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /dev/shm/lldpad.state [ file ]
Source                        mdadm
Source Path                   mdadm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-155.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.6-300.fc23.x86_64 #1 SMP Tue
                              Nov 10 19:32:21 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-12-01 19:13:22 CET
Last Seen                     2015-12-01 19:13:22 CET
Local ID                      12ec9605-8a69-4898-bc28-9d760fd042c8

Raw Audit Messages
type=AVC msg=audit(1448993602.419:778): avc:  denied  { getattr } for  pid=1301 comm="mdadm" path="/dev/shm/lldpad.state" dev="tmpfs" ino=12344 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0


Hash: mdadm,mdadm_t,tmpfs_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-155.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-301.fc23.x86_64
type:           libreport

Potential duplicate: bug 1284262
Comment 1 Jake Jackson 2015-12-11 07:13:29 EST
Description of problem:
sudo mdadm --assemble --scan

Version-Release number of selected component:
selinux-policy-3.13.1-155.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-301.fc23.x86_64
type:           libreport
Comment 2 Lukas Vrabec 2015-12-15 10:42:56 EST

*** This bug has been marked as a duplicate of bug 1288822 ***

Note You need to log in before you can comment on or make changes to this bug.