Bug 1290872 - Director doesn't add correct RHSM subscriptions to overcloud nodes
Director doesn't add correct RHSM subscriptions to overcloud nodes
Status: CLOSED DUPLICATE of bug 1299082
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity high
: y3
: 7.0 (Kilo)
Assigned To: RHOS Documentation Team
RHOS Documentation Team
: Documentation, Triaged
Depends On:
Blocks: 1299082
  Show dependency treegraph
 
Reported: 2015-12-11 13:05 EST by Dan Yocum
Modified: 2016-02-10 23:28 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1299082 (view as bug list)
Environment:
Last Closed: 2016-02-10 23:28:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-12-11 13:05:48 EST
Description of problem:

Related to BZ https://bugzilla.redhat.com/show_bug.cgi?id=1290042

The first thing extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration should do is disable all repos available in a subscription to ensure no extraneous and incorrect package versions are installed, (like SAP, eus, and beta repos).  For instance, the following should be executed in extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration in the portal and satellite case statements:

subscription-manager repos disable=*

Secondly, the following repos (at least) should be enabled on the overcloud nodes:

rhel-7-server-rh-common-rpms
rhel-7-server-openstack-7.0-rpms
rhel-7-server-rhceph-1.3-mon-rpms
rhel-7-server-rhceph-1.3-osd-rpms
rhel-7-server-rhceph-1.3-tools-rpms

This list should be added to extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml

Version-Release number of selected component (if applicable):

7.1

How reproducible:

every
Comment 2 Sanjay Upadhyay 2016-01-15 12:36:08 EST
Here is what I facing with deployment with RHEL 7.1 on overcloud nodes - 

Running a deploy with the following options - 
    -e /home/stack/NUS-OSP/nus_ospd_templates/rhel-registration/environment-rhel-registration.yaml \
    -e /home/stack/NUS-OSP/nus_ospd_templates/rhel-registration/rhel-registration-resource-registry.yaml \

where in the contents of  /home/stack/NUS-OSP/nus_ospd_templates/rhel-registration/environment-rhel-registration.yaml are - 

# to heat stack-create via an additional -e option
# or via the global environment on the seed in
# /etc/heat/environment.d/default.yaml
parameter_defaults:
  rhel_reg_activation_key: "some_activation_key"
  rhel_reg_auto_attach: "false"
  rhel_reg_org: "ORG_ID"
  rhel_reg_pool_id: "Pool_ID"
  rhel_reg_repos: "rhel-7-server-rpms,rhel-7-server-optional-rpms,rhel-7-server-extras-rpms,rhel-7-server-openstack-7.0-rpms,rhel-7-server-openstack-7.0-director-rpm"
  rhel_reg_method: "portal"


While running the install, the node shows this - 


Jan 14 21:55:15 localhost os-collect-config: WARNING: Support for registering with a username and password is deprecated.
Jan 14 21:55:15 localhost os-collect-config: Please use activation keys instead.  See the README for more information.
Jan 14 21:55:15 localhost os-collect-config: WARNING: only 'portal', 'satellite', and 'disable' are valid values for REG_METHOD.
Jan 14 21:55:15 localhost os-collect-config: dib-run-parts Thu Jan 14 21:55:15 EST 2016 06-rhel-registration completed
Jan 14 21:55:15 localhost os-collect-config: ----------------------- PROFILING -----------------------
Jan 14 21:55:15 localhost os-collect-config: Target: pre-configure.d
Jan 14 21:55:15 localhost os-collect-config: Script                                     Seconds
Jan 14 21:55:15 localhost os-collect-config: ---------------------------------------  ----------
Jan 14 21:55:15 localhost os-collect-config: 06-rhel-registration                          5.891
Jan 14 21:55:15 localhost os-collect-config: --------------------- END PROFILING ---------------------
Comment 3 Mike Burns 2016-01-20 17:55:19 EST
We can't really add the ceph repositories by default.  We can't assume that all customers have also purchased ceph and have access to ceph repositories.

We can and should document that you need to add those repos to this file prior to deploying.

We also should fix the couple of repositories that are needed but are missing from that list that can be assumed to be available.
Comment 4 Mike Burns 2016-01-27 10:28:21 EST
We need docs to accurately reflect that users should choose the right activation key and provide the right repositories if they need non-default repos.  Ceph needs to be specified manually because we can't assume ceph is available.
Comment 5 Andrew Dahms 2016-02-10 23:28:36 EST
This issue has also been raised in BZ#1299082, which will be used to track the documentation effort on this topic going forward.

Closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 1299082 ***

Note You need to log in before you can comment on or make changes to this bug.