Bug 1290926 - Migration failed, between two cluster
Migration failed, between two cluster
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.5.4.2
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Francesco Romani
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 17:52 EST by Massimo
Modified: 2015-12-16 05:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 05:15:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Log of the manager (925.05 KB, text/plain)
2015-12-11 17:57 EST, Massimo
no flags Details
Log of the souce host (15.67 MB, text/plain)
2015-12-11 17:59 EST, Massimo
no flags Details
Source Host (14.58 KB, text/plain)
2015-12-14 04:35 EST, Massimo
no flags Details
Destination host (18.59 KB, text/plain)
2015-12-14 04:36 EST, Massimo
no flags Details
VM Log (5.67 KB, text/plain)
2015-12-14 04:44 EST, Massimo
no flags Details

  None (edit)
Description Massimo 2015-12-11 17:52:03 EST
Description of problem:
Hi,
I want to upgrade my oVirt infrastructure, host on host centos 6.x on bare metal 7.x.
I created a new cluster with inside the new host, and when I try to migrate the vm from one cluster to another I have the following messages:
Migration failed, No available hosts found
Migration failed two to Error: Fatal Error during migration. Trying to migrate to another Host

Version-Release number of selected component (if applicable):
Ovirt manager CentOs 6.7, oVirt Engine Version: 3.5.4.2-1.el6
First Cluster with 5 hosts, CentOS release 6.7
Second Cluster 1 hosts, Ovirt Node Hypervison 3.5-0.999.201510261007.el7.centos Bare-Metal
How reproducible:


Steps to Reproduce:
1. start to migrate the vm from cluster in centos 6.x to cluster un centos bare-metal 7.x
Migration started (VM: Spacewalk, Source: ovirtxx3, Destination: ovirtxx5, User: admin@internal).
2. Migration failed due to Error: Fatal error during migration. Trying to migrate to another Host (VM: Spacewalkp, Source: ovirtxx03, Destination: ovirtxx05).
3. Second error: Migration failed, No available host found (VM: Spacewalk, Source: ovirtxx3).

Actual results:
The vm can't migrate from a cluster to anoter one
Comment 1 Massimo 2015-12-11 17:57 EST
Created attachment 1104888 [details]
Log of the manager
Comment 2 Massimo 2015-12-11 17:59 EST
Created attachment 1104889 [details]
Log of the souce host
Comment 3 Tomas Jelinek 2015-12-14 03:05:20 EST
The root cause seems to be this:

"unsupported configuration: Unable to find security driver for label none"

Could you please provide the:
- result of "getenforce" on both source and dest machines
- qemu.conf from both source and dest
- result of "virsh dumpxml rhel6 Spacewalkp01" on source host

Thank you
Comment 4 Massimo 2015-12-14 04:35:11 EST
source host getenforce Disabled
destination host getenforce Enforcing
Comment 5 Massimo 2015-12-14 04:35 EST
Created attachment 1105533 [details]
Source Host

Source Host
Comment 6 Massimo 2015-12-14 04:36 EST
Created attachment 1105534 [details]
Destination host

Destination host
Comment 7 Massimo 2015-12-14 04:44 EST
Created attachment 1105536 [details]
VM Log
Comment 8 Tomas Jelinek 2015-12-14 04:49:06 EST
I think mixing selinux enabled/disabled is not supported.
@Francesco: what do you think? Can you think of any workaround?
Comment 9 Tomas Jelinek 2015-12-14 04:49:13 EST
I think mixing selinux enabled/disabled is not supported.
@Francesco: what do you think? Can you think of any workaround?
Comment 10 Massimo 2015-12-14 06:56:58 EST
I try to disable the selinux on the destination server and now the migration working.
But how i can eneble again the selinux ?
Comment 11 Francesco Romani 2015-12-16 05:15:16 EST
(In reply to Massimo from comment #10)
> I try to disable the selinux on the destination server and now the migration
> working.
> But how i can eneble again the selinux 

Yes, the thing here is that selinux must be consistent on both sides of the migration, otherwise libvirt cannot guarantee a consistent environment.

Not sure there is an official reference in the knowledge base about this upgrade path. If not, I think we should look into libvirt documentation, or ask in libvirt channels.

Since oVirt has no control on selinux state, and since this takes the selinux availability for granted (we assume selinux is on), I'm closing this bug as configuration issue.

Note You need to log in before you can comment on or make changes to this bug.