Bug 1290998 - Papi errors out with every invocation on Power8
Papi errors out with every invocation on Power8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: papi (Show other bugs)
22
ppc64le Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-12 10:31 EST by Jakub Jelen
Modified: 2015-12-16 07:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:43:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelen 2015-12-12 10:31:54 EST
Description of problem:
Actual papi version on Fedora 22 prints errors in the beginning of every invocation.
I was trying to report upstream, but their Trac do not accept any new registration so trying here.
Let me know if there is any more information I should provide or other way to get in touch with upstream

Version-Release number of selected component (if applicable):
papi-5.4.0-3.fc22.ppc64

How reproducible:
deterministic

Steps to Reproduce:
1. Install papi on Power8 machine
2. run papi_mem_info (for example, others result in the same error)

Actual results:
PAPI Error: papi_preset: Error finding event PM_LD_REF_L1.

PAPI Error: papi_preset: Error finding event PM_LD_REF_L1.
[...]

Expected results:
no errors
Comment 1 Jaromír Cápík 2015-12-16 04:02:13 EST
The papi_mem_info is trying to read from non-existing /sys/devices/cpu/events/PM_LD_REF_L1 file. The file exists on P7+.
Comment 2 Jaromír Cápík 2015-12-16 04:18:45 EST
The following kernel patch looks like what you need ...

https://lists.ozlabs.org/pipermail/linuxppc-dev/2015-November/135909.html


... but it's quite recent and not applied to f22 sources yet.
Comment 3 William Cohen 2015-12-16 07:23:10 EST
It looks like libpfm-4.5 in f22 needs the following backported:

https://sourceforge.net/p/perfmon2/libpfm4/ci/506db47a2f0c232f123bdfef0cd281e09bf9f6e3/

Update IBM Power8 event list

The list of available Power 8 performance counter events has been updated.
There are a number of new events that have been added to the list with a
few corrections to existing events.

Signed-off-by: Carl Love <carll@us.ibm.com>
Comment 4 Jaromír Cápík 2015-12-16 07:24:19 EST
libpfm-4.6.0-3.fc23 helped to get rid of the issue
Comment 5 Jakub Jelen 2015-12-16 07:43:52 EST
As noted update libpfm to F23 package helped so we can close this report as it is functional in current release.

Thanks for consultation.

Note You need to log in before you can comment on or make changes to this bug.