Bug 1291005 - python2-dialog conflicts with old python-dialog
python2-dialog conflicts with old python-dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-dialog (Show other bugs)
23
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Zbigniew Jędrzejewski-Szmek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-12 11:30 EST by Christian Dersch
Modified: 2015-12-15 08:22 EST (History)
4 users (show)

See Also:
Fixed In Version: python-dialog-3.3.0-7.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 08:22:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Dersch 2015-12-12 11:30:13 EST
Description of problem: python2-dialog conflicts with old python-dialog as it is not recognized as an update for python-dialog (looks like wrong provides in spec).


Version-Release number of selected component (if applicable): 3.3.0-4.fc23


How reproducible: always


Steps to Reproduce:
1. dnf install python-dialog
2. dnf install python2-dialog

Actual results:
Error: Transaction check error:
  file /usr/lib/python2.7/site-packages/dialog.py from install of python2-dialog-3.3.0-4.fc23.noarch conflicts with file from package python-dialog-2.7-20.fc23.noarch
  file /usr/lib/python2.7/site-packages/dialog.pyc from install of python2-dialog-3.3.0-4.fc23.noarch conflicts with file from package python-dialog-2.7-20.fc23.noarch
  file /usr/lib/python2.7/site-packages/dialog.pyo from install of python2-dialog-3.3.0-4.fc23.noarch conflicts with file from package python-dialog-2.7-20.fc23.noarch


Expected results: python2-dialog comes as an update for python-dialog without conflicts.
Comment 1 Itamar Reis Peixoto 2015-12-12 11:36:54 EST
I don't know the best way to fix it, may be adding an obsolete on it ?
Comment 2 Fedora Update System 2015-12-12 16:34:10 EST
python-dialog-3.3.0-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4e0d2d2e7c
Comment 3 Fedora Update System 2015-12-13 12:21:42 EST
python-dialog-3.3.0-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-dialog'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4e0d2d2e7c
Comment 4 Fedora Update System 2015-12-13 12:29:21 EST
python-dialog-3.3.0-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4e0d2d2e7c
Comment 5 Fedora Update System 2015-12-14 10:50:14 EST
python-dialog-3.3.0-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-dialog'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4e0d2d2e7c
Comment 6 Fedora Update System 2015-12-15 08:22:46 EST
python-dialog-3.3.0-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.