Bug 1291084 - [GTK3] [UI] Wrong "canvas" window size on startup
[GTK3] [UI] Wrong "canvas" window size on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-13 11:23 EST by Anass Ahmed
Modified: 2015-12-14 16:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 16:00:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LibreOffice Calc Internal Canvas has wrong size (127.68 KB, image/png)
2015-12-13 11:23 EST, Anass Ahmed
no flags Details

  None (edit)
Description Anass Ahmed 2015-12-13 11:23:15 EST
Created attachment 1105351 [details]
LibreOffice Calc Internal Canvas has wrong size

Description of problem:
When I open a file using LibreOffice, the internal "canvas" (the editor part with toolbars) of the window appears in a wrong size. This issue affects all LibreOffice apps. This issue happens under X.

I don't know if it's fedora-specific or upstream issue. 

Re-sizing the window fixes the issue.

Version-Release number of selected component (if applicable):
libreoffice-gtk3-5.0.3.2-11.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open Nautilus or any File Manager.
2. Open a directory which contains the document.
3. Open the document using LibreOffice 5.0.3-GTK3.

Actual results:
The internal canvas of the window has a wrong small size.

Expected results:
The internal canvas of the window should have the same size of the screen.

Additional info:
This issue happens under X server, I don't know if it happens under Wayland.
Re sizing the window fixes the issue.
Comment 1 Caolan McNamara 2015-12-14 09:02:13 EST
Can you try with libreoffice-gtk3-5.0.3.2-12
Comment 2 Anass Ahmed 2015-12-14 15:56:31 EST
I've just upgraded to this version and I think it had solved the issue.
Thank you very much.

If I stumbled upon any issues related to the sizing, I'll add it to this bug report.
Comment 3 Caolan McNamara 2015-12-14 16:00:27 EST
closing because reported fixed

Note You need to log in before you can comment on or make changes to this bug.